0

So I attempted to dual boot ubuntu 14.04 and windows 8.1 on my new laptop (aorus x3 plus v3) and it REALLY ruined it. Essentialy broke my new £2000 laptop. I followed this guide (because for some reason ubuntu wouldn't detect windows 8.1, I now realise this may be because I didn't disable secure boot) http://www.everydaylinuxuser.com/2014/05/install-ubuntu-1404-alongside-windows.html?m=1

So partitioning my hard drive reduced my storage capacity greatly. In the first partitioning step in the tutorial I roughly gave half my storage capacity to each OS (I have dual 256Gb ssds). Then in that last step where you partition the free space in the 'other options' I gave the same as in the tutorial, and my RAM was 16Gb so I doubled it and took it away for the switch space. So on and so forth, but when I finally clicked install ubuntu it came up with a weird error. It was just a message box labelled ???? with the contents as ???? ????. I clicked close and it took me back to the list of installation options. I tried other options again but I couldn't find those partitions I had created or the free space I had created it with. So I got sick of it and just went for deleting the other OS, but when I select my timezone that same crazy error comes up and won't let me continue. Sadly, this is AFTER windows was deleted, so now my laptop now has no OS, and a REALLY screwed up hard drive. By the way, I am an ubuntu user, but this is the first time I have tried to dual boot.

If someone can actually help me unscrew this then I will be really surprised but any advice is appreciated. (P.s: unlike in the tutorial above, I created an Ubuntu USB on my other computer that runs ubuntu with the disk creator in 14.04)

  • have you checked the md5 of your downloaded iso, to verify the download is not broken? – DJCrashdummy Jul 16 '15 at 10:00
  • What is the output of sudo blkid from a terminal in Ubuntu Live USB? – solsTiCe Jul 16 '15 at 11:23
  • solsTiCe, it returns this: – Jamie Jul 16 '15 at 15:21
  • /dev/loop0: TYPE="squashfs" /dev/sda: TYPE="isw_raid_member" /dev/sdb: TYPE="isw_raid_member" /dev/sdc1: UUID="A264-6385" TYPE="vfat" – Jamie Jul 16 '15 at 15:26
0

There is some missing information in your question that makes it ambiguous.

1) IF the version of windows is OEM (as in the windows disk is made by dell or hp or whatever) than Install Windows first (one the whole disk)- then use windows dskmgr to shrink the filesystem / partition down - create empty/unused space and make the ufi/uefi partition just a little bit larger - not sure what the max is, it is easy to look up tho - Then install Ubuntu in the unused space and put the ubuntu ufi/uefi file in the same partition as the windows one. The installer will automatically setup your mount points and swap space in the empty space you designated.

2) IF the version of windows is NOT an OEM (as in you have a genuine micr0$0ft disk) than you can and should use ubuntu/gparted to setup your partitions - (windows system partition / ubuntu system partition / UFI/UEFI boot partition / shared free space partition / win space part / ubuntu space part) as an idea - really however you want it. - necessary partitions tho is win part - ubuntu part - ufi/uefi part. - the installers will make their own mount points and swap spaces within the space you designated for each system.

I understand that you have gone through with the install already - however if you want to start over the above should give you a better jumping off point.

Once both systems are installed GRUB2 needs to be able to manage the UFI/UEFI primarily (NOT Windows) - Anytime micr0$0ft updates my laptop (dual booted with Ubuntu studio 14.04 and win 8.1) and corrupts my grub I use this tool -

http://sourceforge.net/p/boot-repair/home/Home/

I just created a bootable USB with the image and keep it in my collection - Honestly, I just run the "recommended repair" and follow the steps - sometimes a couple times - and it does the trick

hope this helps!!

-1

Bleach it clean

Simplest way to start again... boot your USB stick, open a terminal, and

  • Work out which drive is the main drive
  • Wipe it with zeroes (you only need to do a few seconds worth to wipe the partition table)

    sudo fdisk -l <-- Look at the output of this to find the disk that matches the HD

    sudo dd if=/dev/zero of=<the disk> bs=32M

What this does

  • sudo elevates the privileges to root because you need that to write to raw disk devices
  • dd was originally "dupe disk" but it's just a very powerful raw copy utility
  • /dev/zero is a special file on Linux that is just an infinite pool of zeroes - here we're using as the if or input file
  • Replace <the disk> with the right device identifier, e.g. /dev/sda

Beware - the dd command is powerful and can write to raw disk devices when running as root. This means you can wipe any drive connected to the machine - including the USB thumb you're using as a boot disk. Check the output of fdisk very carefully to make sure which disk you want to wipe.

  • I wouldn't advise to wipe it clean until further investigation determine if it is recoverable or not. If you really want to do it there is no need to wipe all the disk. Just use wipefs and you're done. – solsTiCe Jul 16 '15 at 11:20
  • Not to doubt you, but if I decided to do this, would I get the space on those partitions back? Because remember I split up my free space pretty bad and I'm certainly not an advanced enough user to locate them. – Jamie Jul 16 '15 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.