0

I am trying to install onto an ASUS system with an LSI (fake) raid controller. Unlike debian, ubuntu 14 detected it and installed drivers and utilities. Then it creates a RAID 1 as directed. All is well.

But it fails to install a boot loader, grub or lilo. No error details, just "failed to install". So sad. I tried to create a partition for /boot and not have it be part of the RAID but it fails.

How do I install a boot loader onto a RAID?

1

The installer should default to the correct location, but if not, make sure it is set to install grub to the whole array ( /dev/mapper/something on older editions of Ubuntu, /dev/mdXX on recent releases if you have an Intel fakeraid ) rather than an individual drive ( /dev/sda ).

| improve this answer | |
  • Thank you. boot-repair installed it into "/dev/mapper/something" – jnajna Jul 16 '15 at 16:43
  • The boot loader installer failed. I was not trying to do it manually. – jnajna Jul 16 '15 at 20:45
0

This should be done automatically at the end of the Ubuntu server/desktop install. See this guide - Official Ubuntu Guides

On my server, the boot loader got installed on both the HDD's directly (Raid1). If that fails, you can run this command for both your hard drives:

  • grub-install /dev/sdX

X: is the letter of hard drives.

| improve this answer | |
  • grub install fails – jnajna Jul 15 '15 at 21:15
  • can you give more details on the error you are getting? Are you sure this is a software raid controller (or something that's embedded into the motherboard, but is para hardware)? Did you try creating a pure software raid directly in Ubuntu (ignoring the ASUS raid option)? – Jeets Jul 15 '15 at 21:20
  • Official guide links to very old fake RAID guide: help.ubuntu.com/community/FakeRaidHowto – jnajna Jul 15 '15 at 22:24
  • grub-install: not found – jnajna Jul 15 '15 at 23:46
  • Unable to install GRUB on /dev/md126p1 – jnajna Jul 15 '15 at 23:48
0

I am going to try boot-repair.
https://help.ubuntu.com/community/Boot-Repair#A1st_option_:_get_a_disk_including_Boot-Repair

| improve this answer | |
  • This worked. I followed the prompts and ran several commands as directed. – jnajna Jul 16 '15 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.