When I upgraded from 11.04 to 11.10, the setting remained. Now that I have done a clean install of 11.10, the CCSM option does NOT work anymore and I can't seem to find a solution. Also note that I am NOT talking about Unity 2D.

  • I've tried unity --reset and that does not help.
  • Logging out and back in doesn't help
  • Removing the hidden directories in my home directory doesn't help

9 Answers 9


In my case what I did was this:

  1. Install CompizConfig Settings Manager:
    sudo apt-get install compizconfig-settings-manager
    sudo aptitude compizconfig-settings-manager
    or GUI tools like Software Center / Synaptic

  2. Open CCSM with dash menu (Press SUPER to open Dash):

enter image description here 3. Select UNITY plugin:

enter image description here 4. DISABLE AUTO-HIDE

Now you HAVE TO log out or reboot the computer for this to work. Same goes when changing the icon size in the launcher. It does not take effect the first time you change it. Only after rebooting will it work. At least for me.

enter image description here

NOTE - Stopping the Auto-Hide will save some trouble with some windows like the Back Button of Firefox been underneath the Launcher when it "auto-appears". It is VERY IMPORTANT you update the system (Check for updates with the Update Manager and apply all of them). Reboot and then do this answer. This way you save yourself some other troubles that have been fixed already with this minor updates.

As you can see in all the images the Launcher stays there in a fixed position. Saving me some seconds each time I need to search for something.

NOTE2 - Using unity --reset will only reset you to the default config it has after installing 11.10. Same goes for the default icons if you use unity --reset-icons.

  • Thank you for taking the time to generate all these screenshots. However, this is exactly what I'm trying, and it isn't working, because Unity apparently doesn't care what settings I enter in CCSM. Oct 24, 2011 at 1:09
  • I see you have tried a lot of options but just in case, did you try other resolutions?. I mean after a fresh install of Ubuntu 11.10. Did you per chance change the resolution to another smaller one to test how the launcher reacts. Oct 24, 2011 at 2:08
  • I hadn't thought of that before, but I've now tried a multitude of both high and low resolutions with ratios from 4:3 to 16:10 (I have a 16:9 display) with no success in either of them. Oct 24, 2011 at 21:31
  • Can you add to your question a link to a file that contains the ouput of lshw so we know the hardware you have and might help a little bit more with this. Oct 24, 2011 at 23:49
  • Here you go: lshw output Oct 26, 2011 at 21:52

Try this:

Reinstall the CompizConfig Settings Manager

sudo apt-get autoremove compizconfig-settings-manager
sudo apt-get install compizconfig-settings-manager

Then, search for it in the Dash, go to Unity Plugin (or something like that), and in the Experimental tab, you can change its configuration.

After that, restart your session, it should work fine, I just did it.

  • Nope. Launcher still dodges even though "hide launcher" is set to "never"... Oct 19, 2011 at 21:40

I wrote a bug report about this.


Sometimes the problem can be fixed with this:

gconftool-2 --type int --set "/apps/compiz-1/plugins/unityshell/screen0/options`/launcher_hide_mode" 1
sleep 2
gconftool-2 --type int --set "/apps/compiz-1/plugins/unityshell/screen0/options/launcher_hide_mode" 0

This does not work always.

  • Didn't work for me =( Nov 11, 2011 at 0:45
  • By the way, you did see my bug report since earlier, right? Nov 11, 2011 at 0:46
  • I did not see your bug report. A marked mine as duplicate.
    – Timo
    Nov 14, 2011 at 13:19

I was having this exact same problem. After reading through one of the bug reports linked to above, and then following one of the links in there, I found this question: Geforce Go 7300/7400 Blacklisted, Can I Still Run Unity?

It turns out that the video card (in my case a nVidia 7300) was blacklisted, and even though I was logging into "Unity" and not "Unity 2D", it was still falling back to 2D mode because the card is blacklisted.

There is a workaround there about installing the nVidia 173 drivers and forcing Unity mode, and it works for me. I also tried it with the latest drivers, hoping the compatibility issues has been fixed, but the system locked up as soon as I logged in, so I had to go back to the nVidia 173 drivers.

The important parts from the link I posted:

Run /usr/lib/nux/unity_support_test -p. If you get a red "no" next to "Not blacklisted", then you've got this issue. Once you install the nVidia 173 driver, you can edit /etc/environment and add the following line:


Log out and back in, and you should be set. You now have to re-apply the settings in CompizConfig, but this time they should be respected.


(total guess, but update your question with what happens).

Log out, and log in via a tty by hitting Ctrl-Alt-F1.

  1. Reset your Unity configuration by doing a unity --reset
  2. Let's move compiz's settings out of the way in case they're messed up: mv .compiz .compiz-backup
  3. Ctrl-Alt-F7, then log in.
  4. Now try to set the settings via CCSM
  5. Log out and back in.
  • No success - nothing changes... Oct 19, 2011 at 22:17

The "Hide Launcher" setting in CCSM wasn't working for me after updating to 11.10 but I found if I changed the setting to what I wanted and restarted X, it ended up working. Have you by change restarted X after changing the setting?

  • "restarted X"? I'm afraid I don't understand... Oct 19, 2011 at 13:55
  • X is what renders your desktop. I just mean log out and log back in. Normally CCSM settings should apply right away but apparently there's a bug where you have to log out and in again. Oct 19, 2011 at 14:29
  • That doesn't work for me - the settings still show up correctly in CCSM (i.e. hide launcher set to "never") even after a full system reset, but the launcher still doges windows. Oct 19, 2011 at 21:21

You can install gconf-editor and then change the setting by going to:

apps > compiz > plugins > unityshell > screen0 > options

Edit the following option:


Your options are:

Make the launcher hide automatically after some time of inactivity: always or just when the focussed window is not over the launcher (0 = Never, 1 = Autohide, 2 = Dodge Windows, 3 = Dodge Active Window)

I believe the option you are looking for is 0

  • It's set to 0, but the launcher doesn't honor it. Oct 20, 2011 at 21:44

Alt + f2 then type compiz --replace

Restart and try to change the Hide Launcher property on CCSM again.

Try to set it from Never to Autohide, and then Never again.

  • Nope, not working here... Oct 24, 2011 at 1:15

apparently 11.10 is no longer listening to what gconf has to say.

I had to install dconf and use it instead

  • sorry forgot to mention that the setting is under com/canonical/unity-2d/launcher it took me some resizing of the window on my side to get it to show the setting properly, but I got it now. just check the box, then hit your super key. launcher comes up, but doesn't hide :D:D:D:D
    – Joe
    Oct 31, 2011 at 1:43
  • Doing this just makes the launcher disappear for me. Again the OP is asking for the non-2d solution to this problem.
    – Dave
    Nov 4, 2011 at 4:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.