0

I made a major mistake by putting in this code:

vim /etc/lightdm/lightdm.conf 

and then changing the line

greeter-session=unity-greeter 

to

greeter-session=lightdm-gtk-greeter

But now I get a low graphics error. I found some answers on how to fix this, but I am struggling with opening the terminal to do it. The instructions on this website How to change the LightDM theme/greeter? would be helpful if I could get into the terminal, but when I press Ctrl+Alt+F1 nothing happens except the cursor freezes.

So I am looking for a workaround and I considered changing grub as the terminal does open up there. But I ran into a new problem - grub does not recognize sudo and other commands.

  • What happens on Ctrl+Alt+F1? You should get to console. – Pilot6 Jul 14 '15 at 18:51
  • I don't, my mouse freezes and I don't get to the console. I stay on the same low graphics screen. – BJsgoodlife Jul 14 '15 at 18:53
0

If you can get to grub menu, you can choose to boot in recovery mode. Do it.

Then choose the option "root"

There you can run

mount -o remount,rw /
nano /etc/lightdm/lightdm.conf

and edit this file. Then press Ctrl+O to save and Ctrl+X to exit.

Then run

reboot
  • @Pilot6-It doesn't work yet but I was able to follow your commands. What I am thinking is the greeter-session is worded wrong somehow. I was able to find the configuration file. It is /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf – BJsgoodlife Jul 14 '15 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.