1

I downloaded Ubuntu 14.04.2.LTS. When I came to load and compile OpenFOAM-2.4.0 it says cmake, flex, bison, qt4 and OpenMPI are not installed.Today I downloaded those files and are in my home directory.So question is how do I compile those or get them into Ubuntu? Please can someone help with the information I have given.

4

It's probably easier do download and install these packages from the official Ubuntu repositories. Try executing this command in a terminal:

sudo apt-get install openmpi-bin libopenmpi-dev cmake flex bison libqt4-dev

EDIT:

You can also install OpenFOAM directly via their package repository, which already contains version 2.4.0, and will install the required dependencies automatically. From the OpenFOAM website:

VERS=$(lsb_release -cs) 
sudo sh -c "echo deb http://www.openfoam.org/download/ubuntu $VERS main > /etc/apt/sources.list.d/openfoam.list"

sudo apt-get update
sudo apt-get install openfoam240
  • You are welcome! Please consider accepting the answer if you feel your problem has been solved. – mdd Jul 15 '15 at 23:01
  • Thanks but problem is I do not have internet connected to PC.Work frm my BlackBerry cell phone.So I need links copy to my cel then transfer to cel.Also need C++ cxx for SU2_EDU program.Can u please help here too.Thanks – john mcgeorge Jul 17 '15 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.