1

I installed with what I thought were the recommended partitions but I think I may have done something wrong. I'm not loading windows or any other OS and I don't have anything indispensable on the computer. I tried reinstalling trying to use as many default settings as I could. For awhile there it only booted into BIOS and all of my boot options were missing but it would work when I booted with the ubuntu live usb inserted. Fiddling with the settings I can create a new boot option but I don't know where the path is located.

boot repair log : http://paste.ubuntu.com/11878425/

I can reinstall, repartition if I need to.

To clarify booting in CSM mode gave me back an insert bootable disk and retry error. in the boot options I have no options. I reinstalled using UEFI, same problem. Boot repair is currently hung at "purge and reinstall GRUB of:sda3(upd) http://paste.ubuntu.com/11879419/

0

You have newer UEFI capable hardware, but installed in CSM/BIOS boot mode. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode

You then always need to boot in CSM mode, not UEFI nor UEFI with secure boot on. Only in CSM/BIOS mode. It looks like you booted Boot-Repair in UEFI mode & it tried to repair for UEFI boot, but without efi partition it cannot fully fix it. You should just be able to boot in BIOS mode?

Hold shift key to get grub menu as with one install it will not show menu normally.

What brand/model system and what video card/chip? If you get grub menu you may need video boot parameters.

My computer boots to a black screen, what options do I have to fix it?

Or you can reinstall in UEFI mode, you could convert existing swap to efi partition, FAT32 with boot flag to be the ESP - Efi System Partition and add swap at end of drive. You have to be sure to boot installer in UEFI boot mode to install in UEFI mode.

Shows install with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen

https://help.ubuntu.com/community/UEFI

Also shows Windows 8 screens, which you do not need, just skip that part.

Installing Ubuntu Alongside a Pre-Installed Windows with UEFI

  • ASUS Q550L intel i7-4500U cpu @ 1.8g x 4, 64 bit the video card that ubuntu live is showing is INTEL Haswell Mobile but I have an NVIDIA geforce 745m. – Joe Snuffy Jul 14 '15 at 17:12
  • That is a very new Intel system, so you need newest version of Ubuntu or perhaps even newer using ppa to upgrade kernel & drivers. You may need nomodeset boot option in grub if using nVidia. If you plug monitor into motherboard to use Intel it may just work? Best to use UEFI but not absolutely required. – oldfred Jul 14 '15 at 18:31
  • I have 15.04, that's the newest isn't it? I'm not getting a black screen, it either goes straight to BIOS/UEFI or it tells me to add a bootable disk. I reinstalled to in UEFI mode (/dev/sda1 fat32 /boot/efi,/mnt/boot-sav/sda1) – Joe Snuffy Jul 14 '15 at 19:17
  • Make sure secure boot is off in UEFI. Have you tried one time boot key often f10 or f12? Or go into UEFI and make ubuntu entry in UEFI boot tab first boot option? But some systems need this: askubuntu.com/questions/486752/… or: askubuntu.com/questions/597052/… and then you boot hard drive entry in UEFI. – oldfred Jul 14 '15 at 19:59
  • I turned secure boot off and I have no options in the UEFI boot tab. I have >Add New Boot Option and >Delete Boot Option. I have no options to pick from. If I go into the BIOS while the liveUSB is inserted, I get that option but that's all. E: I'm going through your other links too but I really don't know how to use linux so I'm having to google as i go. – Joe Snuffy Jul 14 '15 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.