1

I am using Ubuntu 15.04. I installed Gnome Evolution 3.16 by adding the Gnome PPA in my sources list. This worked briefly, but then Evolution stopped working with my Google Apps accounts (happened on two separate fresh installs, and worked fine initially, but stopped working after I restarted Evolution).

I have since removed Evolution 3.16 (used the Software center to uninstall), and also removed the PPA for Gnome from my sources. I have rebuilt the sources list (apt-get update... and done an autoclean and autoremove as well).

I am getting a number of dependencies unmet errors when I try and install the default Ubuntu tested version of Evolution (ver 3.12) now:

Depends: evolution-common(=3.12.11-0ubuntu3) but 3.12.11-0ubuntu3 is to be installed

Running the install from the terminal results in the following error (using sudo apt-get install evolution):

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies: evolution : Depends: evolution-data-server (< 3.13) but 3.16.0-fta1 is to be installed

Recommends: evolution-plugins but it is not going to be installed

Recommends: spamassassin but it is not going to be installed or bogofilter but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

Any help would be appreciated.

  • Just remove the package with sudo apt-get purge evolution-common – Stefano Mtangoo Jul 14 '15 at 15:43
  • That didn't work - says 'evolution-common' is not installed. – Jeets Jul 14 '15 at 15:45
  • it seems ppa sources are still there so you need to use ppa-purge (see my answer). what does sudo apt-get install -f give? – Stefano Mtangoo Jul 14 '15 at 15:51
2
  1. Add the PPAs again, and yes, I'am sure.
  2. sudo apt-get update && sudo apt-get upgrade
  3. sudo apt-get install -f
  4. sudo apt-get install ppa-purge
  5. Use sudo ppa-purge <the_ppa>to remove the PPAs and to downgrade your GNOME environment
2

You have to add the ppa and purge it out

sudo apt-add repository ppa:gnome3-team/gnome3

Then Update the system

sudo apt-get update

then purge it off

ppa-purge ppa:gnome3-team/gnome3

You can try sudo apt-get install -f to try fixing stuffs

  • great it worked. Care to upvote? ;) – Stefano Mtangoo Jul 14 '15 at 15:52
  • don't have enough rep. points... couldn't even attach images till I get to a rep of 10. Hence to comment above about this solution working. – Jeets Jul 14 '15 at 15:54
  • don't worry! its okay! – Stefano Mtangoo Jul 14 '15 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.