0

I have just re-installed twice Ubuntu because of this problem, I'm only able to see the login screen when I use recovery mode and select File System Check. In other case I just hear the start sound but I can't see anything on my screen, it still works the terminal because I can press Ctrl+Alt+F1 and reboot the system, but I can't see that on the screen, unless as I said using the recovery mode options. I'm sure it happened after the update because I had been rebooting after any install or copying a file from a USB flash drive and I wasn't seeing any problem before I updated.

I also remember that there was a package that was just downloaded 70% and it automatically changed to another package and I'm not sure it downloaded and installed correctly the package.

Before re-installing, I was not sure about the problem and I even tried configurating gdm and didn't work.

0

My problem is very same to your problem, and I solved it this way:.

  1. pressed Ctrl+Alt+F1
  2. sudo rm /home/<username>/.Xauthority
  3. sudo apt-get install --reinstall xorg && sudo reboot.

    In this step you may see the following packages have unmet dependencies. If you see this issue, do a: sudo apt-get clean && sudo apt-get -f install, then issue sudo apt-get install --reinstall xorg again.

  4. sudo reboot
  • It didn't work. I reinstalled it again and then I did dist-upgrade instead the updater and I got the same problem. I entered the system from recovery mode and I did what you said and it didn't change anything. – Victor Miguel García Sanchez Jul 14 '15 at 15:56
  • Do you change permissions on home directory? sudo chmod -R ug+rwx /home/[username] – Xiuyang Sun Jul 14 '15 at 16:44
  • no, do I have to do it before or after removing xauthority? – Victor Miguel García Sanchez Jul 14 '15 at 16:47
  • I recomend you to check your account's authority in home file, cd /home/[username] && ls -l. If some files are root permissions, you should change them – Xiuyang Sun Jul 15 '15 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.