4

I use Ubuntu 14.04 LTS and for some reason I can't scroll with 2 fingers.

I don't have an option to add it in settings:

Settings dialog

I tried installing Synaptic Package Manager and using that to enable it but that didn't work.

The last method I tried was installing focaltech-dkms. I rebooted, but again, nothing changed.

sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms
sudo apt-get update
sudo apt-get install focaltech-dkms
sudo modprobe -r psmouse
sudo modprobe psmouse

Here is my Xinput:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 FocalTech FocalTech Touchpad in mouse emulation mode id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 VGA UVC WebCam                     id=10   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

How can I get it to work?

Output for uname -a:

Linux vlad-X550JX 3.19.0-22-generic #22~14.04.1-Ubuntu SMP Wed Jun 17 10:03:13 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Output for dkms status:

bcmwl, 6.30.223.248+bdcom, 3.16.0-43-generic, x86_64: installed
bcmwl, 6.30.223.248+bdcom, 3.19.0-22-generic, x86_64: installed
focaltech, 1.5~trusty1: added
psmouse, elantech-x551c, 3.19.0-22-generic, x86_64: installed
6
  • Please edit your question and add output of uname -a terminal command. – Pilot6 Jul 13 '15 at 20:10
  • 1
    And also add dkms status command. The touchpad WILL work with this driver ;-) – Pilot6 Jul 13 '15 at 20:11
  • What laptop model (and touchpad version) are you using? You could possibly contribute to the bug report here as well if you don't find any solutions – Wilf Jul 13 '15 at 20:17
  • @Wilf The bug has been reported and already fixed for 15.10. It won't be fixed for current 14.04, but my ppa (hanipouspilot) can be used as a workaround. But as soon as there is linux-generic-lts-wily it will be fixed in 14.04 too. – Pilot6 Jul 13 '15 at 20:19
  • @Pilot6 ok... will trusty be eventually fixed anyway as it is LTS? – Wilf Jul 13 '15 at 20:20
4

The answer is very simple. You installed a wrong Elantech driver first.

This can be fixed by running

sudo dkms remove psmouse/elantech-x551c --all
sudo apt-get install --reinstall focaltech-dkms
sudo modprobe -r psmouse
sudo modprobe psmouse
4
  • Thx man :D. It works :) – Dumitru Vlad Jul 13 '15 at 20:27
  • 1
    @DumitruVlad Did you install Elantech from a deb file, or ppa, or what? It makes sense to remove it too. – Pilot6 Jul 13 '15 at 20:28
  • I love you both guys, for the question and the answer that fixed everything =D (But for some reason dkms did not output psmouse or elantech-x551c on the last line) – deb0ch Sep 24 '15 at 22:59
  • @deb0ch That is because you did not install the wrong Elantech driver. – Pilot6 Sep 25 '15 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.