0

I am having issues with Ubuntu 15.04 not allowing me to keep my monitors from going to sleep when it is locked. (There are issues that occur when they wake up, and want to avoid that.)

I have adjusted "Turn screen off when inactive for:" to "Never" under Brightness & Lock. As well as turned "Suspend when inactive for" to "Don't suspend" in Power. However after only a few minutes I find the monitors to have gone to sleep.

Again, just want the monitors to ALWAYS have signal running to them.

Thanks for any suggestions!

Edit: xset -q output

Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  0    cycle:  0

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled
5
  • post output of xset -q Jul 13, 2015 at 20:00
  • I imagine these are the two you are referencing - Screen Saver: prefer blanking: yes allow exposures: yes timeout: 0 cycle: 0 DPMS (Energy Star): Standby: 0 Suspend: 0 Off: 0 DPMS is Disabled Jul 13, 2015 at 20:08
  • yeah, i thought maybe whatever you did hadn't disabled dpms Jul 14, 2015 at 3:50
  • do you have a screensaver? Jul 14, 2015 at 3:53
  • No screensaver. However I have noticed that it dims pretty soon after it locks. But if I move the mouse before that time, it takes longer (possibly doesn't even dim, haven't tried it for extended period). So it seems there must be a setting with the lock itself to automatically dim after locking? Jul 14, 2015 at 19:23

1 Answer 1

0

Try installing and using xscreensaver. It does everything the gnome-screensaver screenlock does, except that the unlock menu is ugly. It also keeps signal going to your monitors. It's not exactly what you want, but it might work. Also, I don't know how energystar works, but maybe if you blank the screen, even if the monitor says its on, energystar will still take the initiative to put the monitor to sleep. If you're running a screensaver, there's definitely a signal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .