1

I start Vim with a special role, and configure the Compiz widget layer plugin so that this Vim instance belongs to the widget layer. This gives me a scratchpad that I can show on any workspace with one keypress.

However when I alt-tab switch while the widget layer is hidden, the hidden Vim shows up in the switcher. To make this more irritating, if there are visible Vim instances on the workspace, they often don't get focus unless I wait for the switcher to expand to the application windows, and then select a specific window.

I would prefer the hidden Vim not to appear in the switcher, and not to take focus while it is hidden.

Is there a way to configure this?

1

The answer turns out to be the Window Rules plugin. See http://wiki.compiz.org/Plugins/Widget and http://wiki.compiz.org/WindowMatching#Winrules , specifically the Skip taskbar and Skip pager options.

Enter widget=1 for these options to match windows on the widget layer.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.