0

I'm Trying to do a clean install of Ubuntu 12.04 from a live USB made with unetbootin. However after installing, on the first boot, the system encounters some errors and the keyboard and mouse do not work.

Couldn't copy the exact error as I had to do an entire re-install of my old OS to get my computer working again and the lack of a functioning keyboard and mouse make it kinda impossible to do anything but shut down. This error is copied from a post on a different forum however mine was very similar, if not, exactly the same.

modprobe: FATAL: Could not load /lib/modules/2.6.35-22-generic/modules.dep: No such file or directory

I've seen a lot of people having this error but none apply to my problems.

I get a few variations on that error before Ubuntu loads up which seem to suggest that no modules are installed.

I tried installing 12.04 twice as on the first attempt I did a disc error check and found one, a file seemed to be missing but it was just mis-named;

./pool/main/g/grub2-signed/grub-efi-amd64-signed_1.9~ubuntu12.04.7+1.99-21ubuntu3.16_amd64.deb

was missing the "64" on the end. I changed this but after re-naming though I seemed to get the same problems as before but no errors when checking the disc.

All md5sums are OK and the disc check reports no errors but I still seem to have no modules. The same computer works fine with Lubuntu 12.04

What the heck is going on and how can I fix this?



Update and possible insight, give me your thoughts on this:

I've been looking into the files in question, depmod generates modules.dep but I found from linux.die.net that:

"if a version is provided, then that kernel version's module directory is used rather than the current kernel version (as returned by uname -r)."

but modprobe:

modprobe looks in the module directory /lib/modules/'uname -r'

So what may be happening is that a version is specified which does not correlate with uname -r so the directory created and pointer provided for modprobe are different. Does this seem plausible and if so where do I find the version information and change it?

Also why would this be happening with an unmodified .iso?

P.S. I tried changing some bios settings regarding the keyboard and mouse but turning off usb devices just stopped the boot process and gave me a blank purple screen where I expected a grub loader and forcing operation of all usb devices changed nothing.

1

I think I've found the root of the problem, my suspicion was right, I tried installing ubuntu 12.04 again and sure enough, the version stated at grub boot screen is 3.14.0-32 generic and the version that modprobe is trying to find is at 3.2.0-23 generic so my suspicion was right, now this is the cause of my problem but just raises more questions so I'm going to start a second question regarding this finding.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.