2

I just bought a ASUS PB287Q monitor and hooked it up (via HDMI) to my ASUS N550JK-DS521H. Everything works...but the performance of rendering on the external monitor is terrible. The experience on the laptop monitor is however perfect as before.

I've tested with and without monitor mirroring in the system settings. It has no effect on the sluggish experience. I'm suspecting that some kind of software buffering is involved in rendering to the second screen as there is slight delay in the external monitor rendering compared to the builtin screen rendering in mirrored mode.

Is there any use in trying another desktop such as GNOME?

Can I somehow tell Ubuntu to instead use the NVIDIA card (instead of the defaulted Intel) when rendering the external monitor?

Please help.

I'm sitting on 15.04 with its default (compiz) desktop. No software nor physical rotation is involved.

Command lspci -k | grep -EA2 'VGA|3D' outputs

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
    Subsystem: ASUSTeK Computer Inc. Device 11cd
    Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 850M] (rev a2)
    Subsystem: ASUSTeK Computer Inc. Device 11cd
    Kernel driver in use: nouveau

Update: Ok, I've now installed nvidia-346 and nvidia-prime and rebooted.

glxinfo says:

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 850M/PCIe/SSE2
OpenGL core profile version string: 4.4.0 NVIDIA 346.59
OpenGL core profile shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:

But still the same problem with sluggishness (only on external monitor). I'm suspecting compiz... What to try next?

Update I'm on NVIDIA now since prime-select query returns nvidia.

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Jul 12 '15 at 16:10
  • Are you by any chance rotating the monitor? And are you connecting via dp or hdmi? – user3113723 Jul 12 '15 at 16:13
  • Oops. that command (I think) made my system hang...so I hade to reboot. Hang on...I'll see if I can pipe it. This time my system didn't hang. Strange. I added the output. – Nordlöw Jul 12 '15 at 16:32
  • I added new driver to my answer. Maybe it improves performance. – Pilot6 Jul 12 '15 at 16:34
1

You can install Nvidia proprietary driver and switch to Nvidia adapter.

Run in terminal

sudo apt-get install nvidia-346 nvidia-prime

and reboot.

You will be able to switch adapters in Nvidia Settings application.

You can also toggle adapters by running

sudo prime-select nvidia

and

sudo prime-select intel

You will have to log off and on to apply the selection.

For this new adapter you can try a newer driver. Run in terminal

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo add-apt-repository -r ppa:xorg-edgers/ppa

and reboot again.

| improve this answer | |
  • Will that mean that the NVIDIA driver will render both screens? – Nordlöw Jul 12 '15 at 16:19
  • @Nordlöw This is correct. But there may be some trouble with HDMI output. There were some questions related. – Pilot6 Jul 12 '15 at 16:20
  • @Nordlöw You can also setup another DISPLAY for the second monitor, but I can't give a step-by-step solution. – Pilot6 Jul 12 '15 at 16:21
  • So I can't simultaneously have one screen rendered through Intel and another through NVIDIA? – Nordlöw Jul 12 '15 at 16:21
  • @Nordlöw I think you can. But it is not very straight forward. I've never done it myself. Any way it is better to install the driver. – Pilot6 Jul 12 '15 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.