3

I am using Ubuntu 15.04 64 bit, and have the following wine packages installed -

$ apt --installed list|grep wine
wine/vivid,now 1:1.6.2-0ubuntu8 amd64 [installed]
wine-gecko2.21/vivid,now 2.21-0ubuntu1 amd64 [installed,automatic]
wine-mono0.0.8/vivid,now 0.0.8-0ubuntu1 all [installed]
wine1.6/vivid,now 1:1.6.2-0ubuntu8 amd64 [installed,automatic]
wine1.6-amd64/vivid,now 1:1.6.2-0ubuntu8 amd64 [installed,automatic]
wine1.6-i386/vivid,now 1:1.6.2-0ubuntu8 i386 [installed,automatic]
winetricks/vivid,now 0.0+20140302-0ubuntu2 all [installed]

I want to install .NET 2.0 (dotnet20).

  1. Since I'm on a 64bit machine, I set wineprefix and environment like so

    $ export WINEPREFIX="/home/usr/.wineprefixes/office2010/"
    $ export WINEARCH="win32"
    
  2. However, installing dotnet20 gives me the following error

    $ winetricks dotnet20
    Executing w_do_call dotnet20
    Executing load_dotnet20
    Executing w_do_call remove_mono
    Executing load_remove_mono
    ------------------------------------------------------
    Mono does not appear to be installed.
    ------------------------------------------------------
    Executing w_do_call fontfix
    Executing load_fontfix
    Setting Windows version to win2k
    Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
    Current wine does not have wine bug 30845, so not applying workaround
    Executing wine dotnetfx.exe
    fixme:advapi:DecryptFileA ("C:\\users\\usr\\Temp\\IXP000.TMP\\", 00000000): stub
    err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
    err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
    fixme:advapi:LsaOpenPolicy ((null),0x33f2e4,0x00000001,0x33f2d0) stub
    fixme:advapi:LsaClose (0xcafe) stub
    err:msidb:get_tablecolumns column 1 out of range
    err:msidb:get_tablecolumns column 2 out of range
    ------------------------------------------------------
    Note: command 'wine dotnetfx.exe' returned status 84.  Aborting.
    ------------------------------------------------------
    

    The installer on wine quotes on a message box Installation package could not be opened. Contact the application vendor to verify this is a valid Windows installer package

  3. I have tried opening the winetricks GUI and installing from there (the changed WINEPREFIX has been recognized). I have also tried env WINEARCH=win32 WINEPREFIX=/home/usr/.wineprefixes/office2010/ winetricks dotnet20, but I get the same error.

  4. I have also tried uninstalling wine-mono, and then installing dotnet20, but no avail. So, I reinstalled the mono package.

A thread says installing Wine1.7 from the PPA is one way to make things work. However, since that is not a stable version I do not wish to install it. Can I make dotnet20 work with Wine1.6xx ?

2

To solve this error:

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated.

you need to install winbind:

sudo apt-get install winbind

This Samba package provides a daemon which integrates authentication and directory service (user/group lookup) mechanisms from a Windows domain on a Linux system.

This will probably fix your main error:

Note: command 'wine dotnetfx.exe' returned status 84. Aborting.

as .NET does require a working ntlm_auth.

Related:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.