0

I have an FSL Zero Bluetooth headset which was working fine with Ubuntu until a recent update. I'm on Ubuntu 15.04. The headset is recognised as a Bluetooth device and gets connected but doesn't appear in Sound Settings. When I execute the following command, it appears in the Sound Settings but then cannot be switched to A2DP (even though the option is presented), making it unusable:

sudo -i pactl load-module module-bluetooth-discover

I have tested the headset with other devices to ensure that the headset is not at fault.

How should I get the headset to appear automatically in Sound Settings, as it did before recent updates? How can I get the headset to be used with A2DP?

1

I had the same problem and for several months I have tried all possible solutions I could find to no avail,... until today!

I found the solution in post #17 in the following https://bbs.archlinux.org/viewtopic.php?pid=1526534#p1526534 (tnx SimFox3)

What I did:

First copy the files I edited

sudo cp /etc/bluetooth/audio.conf /etc/bluetooth/audio.conf_tmp
sudo cp /etc/pulse/default.pa /etc/pulse/default.pa_tmp
sudo cp /usr/bin/start-pulseaudio-x11 /usr/bin/start-pulseaudio-x11_tmp

Edit /etc/bluetooth/audio.conf

sudo nano /etc/bluetooth/audio.conf

This is in my audio.conf

# Configuration file for the audio service
# This section contains options which are not specific to any
# particular interface
[General]
Enable=Gateway,Source

# Switch to master role for incoming connections (defaults to true)
Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket
Disable=Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=HCI

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=2

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=true

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0

Edit /etc/pulse/default.pa

sudo nano /etc/pulse/default.pa

comment out (with an # at the beginning of the line) the following line #load-module module-bluetooth-discover

now edit /usr/bin/start-pulseaudio-x11

sudo nano /usr/bin/start-pulseaudio-x11

and after the lines

if [ x”$SESSION_MANAGER” != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
fi

add the following

/usr/bin/pactl load-module module-bluetooth-discover

Restarted and I was finally able tot switch to A2DP

Hope it works for you too.

  • Hi @RobertFM. Thank you very much for your detailed suggestions. I went through all of your instructions, but without success unfortunately; the headset just won't switch to A2DP like it used to. Quick question: In order to get the device even to show up in sound settings, I have to now run the command sudo -i pactl load-module module-bluetooth-discover. Do you have to do this or was there something you did that made you not have to do this? – d3pd Jul 21 '15 at 21:39
  • 1
    I did remove and re-paired my bluetooth headset. You can try to use pavucontrol to switch to A2DP. Also open a terminal and run "tail -f /var/log/syslog" (whithout "") and see what happens when you connect your headset and try to switch to A2DP. – RobertFM Jul 23 '15 at 7:49
  • 1
    Also , on my desktop I have to have my bluetooth dongle plugged in to a USB2.0 hub to get my bluetooth headset to work correctly and without skipping. Somehow my belkin dongle does not work correctly in a USB3.0 port. – RobertFM Jul 23 '15 at 7:56
  • 1
    Also, I just noticed that the last bit of the answer was not formatted correctly. Make sure you edit /usr/bin/start-pulseaudio-x11 and add "/usr/bin/pactl load-module module-bluetooth-discover" before the last "fi". – RobertFM Jul 23 '15 at 8:04
  • 1
    Did you use pavucontrol to change to A2DP? You could also try to install blueman and run blueman-manager and try to switch from there. – RobertFM Jul 27 '15 at 13:43
-1

Sorry for the delay but I hope my post will helped someone.

Obviously, for my part, on ubuntu-mate 14.04 the problem was an old version of blueman (the gui bluetooth manager)

I have just install the ppa of blueman and install the latest version for my version of ubuntu.

Voilà

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.