I am having major issues with Ubuntu and Kubuntu with regards to Java on websites using Chromium, Google Chrome or Firefox.

I have tried everything to install Java, but it's not happening. Ubuntu 10.10 is fine, but the new Unity will not run Java. Can anyone provide a step-by-step way to install Java?

  • Installing icedtea-plugin doesn't work
  • Java plugin don't work in x64 Ubuntu :(
    – Extender
    Oct 8, 2011 at 16:06

7 Answers 7

cd /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/jvm/java-6-sun- libnpjp2.so

Restart chromium-browser.

Or if you have the latest 64-bit version (installed in /usr/lib/jvm/jre1.7.0/) use this as the second command:

sudo ln -s /usr/lib/jvm/jre1.7.0/lib/amd64/libnpjp2.so libnpjp2.so
  • 1
    I just tried this, but it's not working as expected. I tried testing it here. The browser does recognize the plugin and asks if I want to enable it (only this time or trust the website). However, the area where the applet should appear remains greyed out, and the applet does not seem to be running. Using jre1.7.0_09 here.
    – JulioHM
    Jan 10, 2013 at 8:55
sudo apt-get install icedtea-plugin

This worked for me in Kubuntu 11.10 to get JAVA working on the computer; however, it still does not get JAVA to work in Chrome or Firefox.

  • It's said in the question that installing that package is not working. And that doesn't solve Chrome and Firefox issue
    – NorTicUs
    Nov 7, 2012 at 11:04
  • This worked fine in Ubuntu 13.10 - Google Chrome V:32.0.1700.77 (Official Build 244503)
    – pst007x
    Jan 25, 2014 at 22:23
sudo apt-get install openjre-6-jre icedtea6-plugin

should be enough to pass the Java test here: http://java.com/en/download/testjava.jsp in Chromium. Firefox is a different issue.

However, I am still stuck on some other issues. openjdk-7-jre would be preferred, but there is no icedtea7 yet in Oneiric universe. So on the JDK side, when I use

sudo update-java-alternatives -s java-1.7.0-openjdk-amd64

I will get the error

"update-alternatives: error: no alternatives for -javaplugin.so."

  • you can do sudo apt-get install openjre-7-jre icedtea-7-plugin
    – Natim
    Mar 22, 2013 at 9:55

The best solution I found, (none of these suggestions worked for me), is as followings: First install Icedtead pluging by:

  • 1) sudo apt-get install icedtea-7-plugin

Then in your chrome browser go to:

  • 2) chrome-> Settings-> Show Advanced Settings-> Privacy then click on Content Settings -> Plug-ins then click on Disable Individual Plug-in
  • 3) Disable both "IceTea-Web Plugin" and "Java(TM)"
  • 4) Restart the browser.
  • 5) chrome-> Settings-> Show Advanced Settings-> Privacy then click on Content Settings -> Plug-ins then click on Disable Individual Plug-in
  • 6) Enable only "IceTea-Web Plugin"
  • 7) Enjoy !

I had the same problem with the Java plugin not working in Chromium or Firefox. I use the Oracle JDK's for Java 6 and 7.

Oddly enough, after playing around and not finding any solution that worked, I disabled the plugin in Chromium, and the re-enabled it again - and the Java plugin works, in both Chromium AND Firefox.

I did end up with Chromium not shutting down properly, but after shutting down these processes, it started normally, and the Java plugin still worked. Weird or what?


To get Java working in the browser

sudo apt-get install icedtea-plugin

Install Oracle (Sun) Java JRE by hand: http://sites.google.com/site/easylinuxtipsproject/java

Easy to do, just requires precision in applying the how-to. :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .