2

I want to use "German, no dead keys" (as "tot" as the layout. Whenever I log into KDE from KDM, I get the regular "German" keyboard. In other questions here I read that you have to switch the keyboard in the login screen, but apparently KDM does not offer that option.

Interstingly, it show "tot" in the systray when I log in, but then switches to "de" once the jingle plays.

What can I do about that?

1

Maybe

Sometimes the KDE setting files get damaged. Then the KDE will fall to the sane default settings.

Test

  1. Make a new user. System Settings > User Management
  2. Log in as the new user

Does the new user have the same problem ?

If no

Rename (/remove) the old user's ~/.kde/share/config/kxkbrc file when the old user's session is not running.

Here

Here the "eliminate dead key" seems to work without problems.

  • I deleted the config file, created it new and it seems like it works. What happens now is that KDE freezes for some 5 seconds before playing the welcome jingle and letting me do anything … that started to happen on a second account some while ago too … – Martin Ueding Oct 13 '11 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.