5

Hey guys so I am trying to allow my friends to connect to my ftp server (I am hosting it on Ubuntu Server 15.04), so I set the pasv_address in the configuration and the port range in the configuration and router. But it still doesn't work. Here is what filezilla says:

Response: 227 Entering Passive Mode (0,0,0,0,203,228). Command: LIST Error: The data connection could not be established: ECONNREFUSED - Connection refused by server Error: Connection timed out Error: Failed to retrieve directory listing

And here is my configuration: http://pastebin.com/j1ZyK7K8

2
  • Are you sure your ISP allows you to run an FTP server on your internal network? (some ISPs "up-sell" you a "business connection" that do allow you to do things like this)
    – Fabby
    Jul 10 '15 at 23:29
  • I used to have it working, a few months ago, but I accidentally crashed the server and I couldn't access it to see what I did. Jul 10 '15 at 23:40
7

Late answer, but here goes:

I have all the options turned on like you. It is required, but still won't work.

pasv_enable=YES
pasv_min_port=xxx
pasv_max_port=yyy
pasv_address=

After these 2 lines change, it is working

listen_ipv6=NO
listen=YES
1

sudo nano /etc/vsftpd.conf

pasv_enable=Yes

pasv_max_port=10100

pasv_min_port=10090


iptables -I INPUT -p tcp --destination-port 10090:10100 -j ACCEPT


sudo ufw allow 10090:10100/tcp


Try allowing Anon login to make sure its not a user/pwd problem. Not sure what pasv_address is. but I have a domain name, so maybe its needed for IP? BTW Check out duckdns for free DNS!

3
  • @derek-lesho: if the above doesn't work, drop me a note @ Fabby below.
    – Fabby
    Jul 11 '15 at 8:50
  • I tried this but I am still having the same error. When entering passive mode it says:Command: PASV Response: 227 Entering Passive Mode (0,0,0,0,39,106). Why are there 0s instead of the ip? Jul 11 '15 at 19:20
  • Do you want me to send the ip and password of my server so you ssh into it and try to find the problem? Jul 11 '15 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.