1

I've checked around the questions from people with similar problems but none of the solutions that succeeded for them have resolved my problem. I edited the Document Root in my 000-default.conf and my default-ssl.conf files and changed their path from /var/www/html to what I wanted. I also included Directory tags in both of these files as well as the 'apache2.conf` file. I've listed the relevant sections (in my opinion) of each file below. I am using Ubuntu 14.04 and Apache 2.4.7

apache2.conf

<Directory />
Options FollowSymLinks
AllowOverride None
Require all denied
</Directory>

<Directory /usr/share>
AllowOverride None
Require all granted
</Directory>

<Directory /home/conor/Documents/SPUR/loginRegister/style>
Order allow,deny
Allow from all
Require all granted
</Directory>


#<Directory /srv/>
#   Options Indexes FollowSymLinks
#   AllowOverride None
#   Require all granted
#</Directory>

000-default.conf

DocumentRoot /home/conor/Documents/SPUR/loginRegister/style
<Directory /home/conor/Documents/SPUR/loginRegister/style>
Order allow,deny
Allow from all
Require all granted
</Directory>

default-ssl.conf

    DocumentRoot /home/conor/Documents/SPUR/loginRegister/style
    <Directory /home/conor/Documents/SPUR/loginRegister/style>
    Order allow,deny
    Allow from all
    Require all granted
    </Directory>

I made sure to restart the server and reloaded the localhost page and always get this error.

You don't have permission to access / on this server.

  • 403 errors are likely due to a permissions problem. The files/ directories in question need to be accessible to www-data. Post the exact error message in your logs. You may want to look at home directories - a2enmod userdir – Panther Jul 10 '15 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.