5

I already asked this on Firefox support but still no anwer so maybe someone here knows how to fix this.

After I updated Firefox to version 39 I can't use it at all, it crashes all the time, I couldn't even write this question from Firefox. I clicked on "Refresh Firefox" button, also I restarted with addons disabled, also I reinstalled Firefox but none of that helps. Crashes are random, after 5-6 minutes of browsing.

You can see crash reports here: https://support.mozilla.org/en-US/questions/1071421

EDIT: I installed developer edition of Firefox and no crashes so far

  • I also have this problem! It has crashed at least 20 times today! Do you think we could hope to an update to fix this? I don't want to change my firefox branch. – MakisH Jul 10 '15 at 19:30
  • @MakisH It should be fixed soon, many users reported this issue: support.mozilla.org/en-US/questions/1071421 – Alen Jul 10 '15 at 19:36
  • For me it was probably the freshplayer plugin. I removed it and it is now stable again! :-) – MakisH Jul 12 '15 at 21:15
  • If you disable Shockwave Flash plugin, you could fix this problem. – user429043 Jul 13 '15 at 3:31
1

After many attempts, I have a fix for this. The problem lies with Firefox version 39 and the Flash plugin. Either the Adobe or the Pepper flash.

What I have done is totally delete the flash plugins, install the Pepper flash, and download Firefox 39 from Mozilla, and overwrite Firefox 39, which came from the Ubuntu repositories.

The very first thing is to delete all Adobe flash installations

dpkg-query -l | egrep 'flash|fresh'

Now delete these with the purge option, using the file names returned from the dpkg-query command:

dpkg --purge <file_names>

Now you can install the pepperflash from webupd8:

sudo apt-get install pepperflashplugin-nonfree
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin

Now you will need to download the latest version of Firefox from Mozilla, as the version from Ubuntu seems to have issues. First step is to backup, for just in case something breaks:

sudo tar -cvPpf ~/Firefox-backup.tar /usr/lib/firefox*
sudo wget -P /usr/lib/firefox https://download-installer.cdn.mozilla.net/pub/firefox/releases/39.0/linux-x86_64/en-US/firefox-39.0.tar.bz2
sudo tar -C /usr/lib/ -jxvf /usr/lib/firefox/firefox-39.0.tar.bz2

Now you should be able to start Firefox and watch video without the constant crashes.

| improve this answer | |
0

I have just updated from the trusty repositories with absolutely no problems.

With this type of problem, in the first place I would try to remove firefox completely and reinstall; something along the lines of:

sudo bash
aptitude update
aptitude purge firefox
aptitude install firefox

(If you don't use/like aptitude, then apt-get should also work in much the same way.)

Another trick that sometimes has worked for me is to purge the caches Firefox uses. If you don't care about having to create anew your settings, bookmarks, etc., then you can clean all that up with:

 rm -r ~/.mozilla/firefox ~/.cache/mozilla/firefox

and the next time you start up Firefox it should re-create appropriate directories automatically.

Failing this, it is also possible that an error exists in dependencies between packages, e.g. due to an incomplete installation of firefox without all the necessary dependent packages. In this case, upgrading completely the system can also be necessary:

aptitude safe-upgrade

The packages for Firefox version 38 still seem to be physically on the Ubuntu server (list here: http://archive.ubuntu.com/ubuntu/pool/universe/f/firefox/). Unfortunately, it does not seem possible to downgrade from 39 to 38 using the instructions found in the answers to previous question How to Downgrade a Package via apt-get? . apt-cache only knows about versions 39 and 28 at this time, has "forgotten" all intermediate versions.

Hope that helps.

| improve this answer | |
  • I did everything you suggested but it's still the same. Is there any chance to revert to version 38? – Alen Jul 10 '15 at 13:44
  • @Alen Added the information to my answer. Short version: no, it does not seem possible. Either you get version 28, or 39. I am starting to think your upgrade was incomplete, with some packages that were not completely installed. Were there any error messages? In any case, "aptitude safe-upgrade" should be able to help. – ALAN WARD Jul 10 '15 at 14:27
  • No, there weren't any error messages. Thanks for your help, I installed developer version and it's ok now, version 40 will be stable soon so I hope it won't cause any trouble. – Alen Jul 10 '15 at 15:42
  • @Alen So it seems the problem was with this particular version - and you were quite right to make a bug report to the Firefox project. – ALAN WARD Jul 10 '15 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.