0

I installed Ubuntu 12.04 on my mac.and I uninstalled it and but after that when I boot up using rEFind. it shows me an Linux icon saying that boot Linux from whole disk space.how can I get rid of it?.

1 Answer 1

0

There are several ways to do what you want:

  • In refind.conf, uncomment the scanfor line and ensure that it does not include the hdbios option. This will also have the effect of removing any other BIOS-mode boot options from the menu (at least for your internal disk), so if you're dual-booting Windows, this option may be undesirable.
  • In refind.conf, use the dont_scan_volumes option, and specify any unique subset of the description you want to remove, such as dont_scan_volumes "whole disk", assuming no other entry you care about includes the string "whole disk".
  • Using a Linux emergency disk, wipe GRUB from the MBR of the hard disk by doing something like sudo dd if=/dev/zero of=/dev/sda bs=440 count=1. This command is potentially quite dangerous! If you get any of the options wrong, you could seriously damage your partition table or even permanently destroy data on your hard disk. This command should take a fraction of a second to execute. Also, you must NOT issue the equivalent of this command in OS X, since OS X's version of dd doesn't let you specify partial-sector block sizes (bs=440).

If you opt to edit refind.conf, you must locate it. If your rEFInd installation is an old one or if you used the option to install it to your OS X root (/) partition, it will be /EFI/refind/refind.conf. If your rEFInd installation is newer, it's more likely to be in that directory on your ESP, which you'll need to mount:

mkdir /Volumes/ESP
sudo mount -t msdos /dev/disk0s1 /Volumes/ESP

refind.conf will then probably be at /Volumes/ESP/EFI/refind/refind.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.