0

I just received a Meizu MX4 and have already started hacking away at it. One problem I have run into involves not having permission to run executable scripts and files located in the home directory.

I understand that this is probably a security feature. The problem is I can't find a way to override it. The fstab entry for /home makes no mention of noexec:

/userdata/user-data /home none bind 0 0

I have tried explicitly remounting it with rw and exec options, (after remounting root as rw), I have tried playing about with chmod to no avail. Is there a way to fix to this?

I know there are workarounds – call an interpreter/ld-linux-armhf.so.3 to run the executable; move it to another directory and symlink to it from inside home. But I am looking for a way to explicitly run an executable inside /home.

0

Found an answer here: why ubuntu touch terminal cannot execute app

Apparently it has to do with the Terminal app's apparmor settings.

Run sudo nano `ls /var/lib/apparmor/profiles | grep "terminal"` and replace the lines indicated in the link with /** pix, (remember the comma, if omitted terminal app will stop working) and restart.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.