I have some strange wireless connection problems after upgrading to 10.10. I was using 10.04 before and everything was fine.

The problem

I can connect to my access point but I'm constantly losing the connection randomly. I can surf for 5 minutes or 2 hours without any problem and then it simply looses the connection. It tries to reconnect but fails and starts asking me for the password again. Retyping it and hitting connect doesn't help. After a lot of time it eventually connects again.

I have tried to delete the connection in the connection manager and to reconnect again as if it would be a new connection. Then it works instantly.

I have no clue how to solve it nor was I able to find any answer on the internewbz.

EDIT: Providing some lines of syslog.

Oct 12 20:04:45 lenovo-t60 NetworkManager[824]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Oct 12 20:04:45 lenovo-t60 NetworkManager[824]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Oct 12 20:04:48 lenovo-t60 wpa_supplicant[907]: Trying to associate with 00:1b:11:fe:51:02 (SSID='home' freq=2457 MHz)
Oct 12 20:04:48 lenovo-t60 NetworkManager[824]: <info> (wlan0): supplicant connection state:  scanning -> associating
Oct 12 20:04:48 lenovo-t60 kernel: [41340.246963] wlan0: direct probe to 00:1b:11:fe:51:02 (try 1)
Oct 12 20:04:48 lenovo-t60 kernel: [41340.444098] wlan0: direct probe to 00:1b:11:fe:51:02 (try 2)
Oct 12 20:04:48 lenovo-t60 kernel: [41340.644099] wlan0: direct probe to 00:1b:11:fe:51:02 (try 3)
Oct 12 20:04:48 lenovo-t60 kernel: [41340.844079] wlan0: direct probe to 00:1b:11:fe:51:02 timed out
Oct 12 20:04:58 lenovo-t60 wpa_supplicant[907]: Authentication with 00:1b:11:fe:51:02 timed out.

This pattern is repeating over and over again. Tell me if you think there is any other log files which might be of interest. I've looked through them already and couldn't spot anything but maybe I've missed something.

  • I think it would help if you could post some appropriate sections of logs from /var/log – txwikinger Oct 12 '10 at 18:29

Try installing linux backports for wireless:

sudo apt-get install linux-backports-modules-wireless-2.6.35-22-generic && sudo apt-get install linux-backports-modules-wireless-maverick-generic


|improve this answer|||||
  • Sorry had to revert the accept because it didn't solve it. – Octavian A. Damiean Oct 15 '10 at 21:14

This problem is related to the current Intel wireless driver.

I've found a temporary solution on this bugtracker site. It is actually a workaround.

|improve this answer|||||
  • Many thanks for that, @OctavianDamiean - unfortunately, the bugtracker page now says "Drupal Site off-line - The site is currently not available due to technical problems. Please try again later. Thank you for your understanding.", and there is no google cache, nor archive.org cache. Damn it - I so wanted to read what the problem is! This Ubuntu bug refers to that page, though: bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/752829 ... Many thanks again - cheers! – sdaau May 14 '12 at 15:18

Just try to install some more recent wifi kernel modules. - They can come from Ubuntu repositories if you enable the backport repository on your system first.

If you are on Maverick install linux-backports-modules-wireless-maverick-generic. If you are on Natty install linux-backports-modules-cw-2.6.39-natty-generic.

|improve this answer|||||

Ok, here is what I have right now:

$ uname -a
Linux ljutntcol 2.6.38-15-generic #59-Ubuntu SMP Fri Apr 27 16:04:29 UTC 2012 i686 i686 i386 GNU/Linux
$ cat /etc/issue
Ubuntu 11.04 \n \l
$ lspci | grep Wireless
01:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Same problem as everyone else - wireless keeps dropping (for me, with the wireless connection at work), where tail -f /var/log/syslog typically will report:

NetworkManager[14163]: <warn> (wlan0): link timed out.

I have even had the situation where I held my netbook like maybe 50 cm away from a relatively new Cisco wireless node at work - and it would still keep on disconnecting! However, strangely, at home, I have no problems whatsoever being on the wireless; possibly because at home I have just a plain WEP authentication; but at work I have to use 'PEAP with TKIP/MSCHAPV2'.

Anyways, first I tried installing linux-backports-modules-cw- as @sokai and @dhojgaard recommended; by this time, there is now for Natty (11.04) the 3.0.0 version, so I tried:

$ sudo apt-get install linux-backports-modules-cw-3.0.0-natty-generic
The following NEW packages will be installed:

... and rebooted - but no dice, still link would time out. So I did:

$ sudo apt-get remove --purge linux-backports-modules-cw-3.0.0-natty-generic
$ sudo apt-get autoremove --purge

Then finally I found this thread, which refers to a bug related to my wireless network adapter:

Within this thread, there is a recommendation to use wicd - which is something like a network manager (along with a GUI) for wireless stuff.

So I did:

$ sudo apt-get install wicd

and then rebooted - then both NetworkManager and wicd GUI applets are started and shown in toolbar.

However, for one, it seems wicd cannot work with NetworkManager running in the background; some people remove network-manager - but I found it easier to just stop it:

$ sudo service network-manager stop

... and this causes the toolbar GUI icon to disappear as well.

So, at this point, I can choose "Refresh" from "Wicd Network Manager" GUI, and the networks are being scanned and found. Note that there is a separate wicd log:

$ find / -xdev -name 'wicd*' 2>/dev/null    # to find the log file
$ tail -f /var/log/wicd/wicd.log

... and I also observe at the same time tail -f /var/log/syslog.

Now at this point, I try to connect to the work wireless network, but I cannot get it to connect, and wicd in the log complains about bad password (which was definitely correct):

2012/05/15 10:14:07 :: iwconfig wlan0
2012/05/15 10:14:08 :: WPA_CLI RESULT IS ASSOCIATED
2012/05/15 10:14:09 :: WPA_CLI RESULT IS ASSOCIATED
2012/05/15 10:14:09 :: iwconfig wlan0
2012/05/15 10:14:10 :: WPA_CLI RESULT IS ASSOCIATED
2012/05/15 10:14:11 :: wpa_supplicant authentication may have failed.
2012/05/15 10:14:11 :: connect result is Failed
2012/05/15 10:14:11 :: exiting connection thread
2012/05/15 10:14:11 :: Sending connection attempt result bad_pass
2012/05/15 10:14:11 :: ifconfig eth0
2012/05/15 10:14:11 :: ifconfig wlan0
2012/05/15 10:14:12 :: Forced disconnect on
2012/05/15 10:14:12 :: iwconfig wlan0

However, at this point, I realize that whenever a connection is attempted, something called vpnagent appears in /var/log/syslog:

kernel: [  146.999858] wlan0: associated
vpnagent[1219]: Function: tableCallbackHandler File: RouteMgr.cpp Line: 1694 Invoked Function: recv Return Code: 11 (0x0000000B) Description: unknown 

Then I check in the process list:

$ ps ax | grep vpn
2539 ? S 0:01 /opt/cisco/vpn/bin/vpnagentd 

... and finally I remember - this was a Cisco VPN client that we had to use to connect to work VPN network... what I wasn't aware off, however, was that the VPN client actually installs a service/daemon, which runs in the background, and is started at boot!

So, I kill the vpn service:

$ sudo killall vpnagentd

... and I re-run the 'Connect' button on the desired networ in Wicd Network Manager GUI - and FINALLY I get to connect to the network!

Actually, I'm writing this using wicd - and the wireless network even 'fell' once (quote a bit of users, and signal is not strongest) - but wicd reconnected without a problem!


Well, I hope at least that this solves my wireless woes - and that this may help others,


|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.