8

I just bought a Microsoft Designer Mouse, specs here, (Bluetooth 4.0) and am not able to use it in Ubuntu 14.04. On the Windows 8 (same laptop computer) it works just fine.

So I've searched arround and found many people with the same issue. Apparantly the issue is that ubuntu 14.04 only has BlueZ 4.101 as of now, and it would take BlueZ 5.x to support Bluetooth 4.0 Low Energy Device, which seems to be hard to install. There's a thread running from April 2013 to recently on the issue, stating that it's hard to incorporate Bluez 5.x on Ubuntu.

Some people gave some non working suggestions, including the installation of a PPA that lead to me having to reainstall ubuntu (bluetooth wouldn't turn on and ubuntu would hang indefinitly on shutdown):

So isn't there a solution at all? I can't use Bluetooth 4.0 on Ubuntu 14.04 LTS, although the hardware supports it? Is there another Linux distribution that would support Bluetooth 4.0 (Like Mint or someother)?

No one said explicitly that there isn't a solution, probably because there are stuff a very experienced user could do according to his own case.

Seems like a thumbs down for ubuntu.

Thx in advance.

  • To make automatucally connect a mouse (or, AFAIK any device), you have to enter a code on pairing. In my case, a Thinkpad Lasermouse connects automatically on session start with the default "0000". – user500226 Feb 1 '16 at 1:02
4

I got the Microsoft Designer Mouse working on Ubuntu 14.04 with the following PPAs and package installs:

sudo apt-add-repository ppa:vidplace7/bluez5
sudo apt-add-repository ppa:blueman/ppa
sudo apt-get update
sudo apt-get install bluez
sudo apt-get install blueman

Then you need to restart blueman just incase.

killall blueman-manager
blueman-applet &
  • Thank you for the suggestion, but when I tried using that PPA, as per the link above, my Ubuntu stopped working properly. On reinstall I lost my Windows partition and life got gloomy (my mistake). Thank you for your unswer. It's probably the way to go, but given my past experience I will sit PPAs out for now. – A. Vieira Aug 14 '15 at 16:04
  • Wow, I am really sorry that happened! My apologies. I know how it feels to be stuck in installation-hell. :( – Chris McCormick Aug 15 '15 at 13:05
  • Yeah... I'm on a fresh ubuntu 14.04 LTS install trying the ppas above, but my terminal is stuck while doing $ sudo apt-get install bluez . It's stuck on the instruction Installing new version of config file /etc/init.d/bluetooth . Actually this is the second time trying it, because on the first time I stopped the installation there and tried to reboot,. The system was broken and ubunutu wouldn't load. So I had to reinstall the OS again. And I'll have to do it again as it wont budge. How did you get this installed in your ubuntu without breaking stuff? This doesn't work on a fresh install.. – A. Vieira Sep 7 '15 at 13:56
  • It worked for me at the time of posting but unfortunately when I tried an upgrade I got the same behaviour as you. Seems like the upstream bluez5 and blueman repositories are a bit unstable. :( – Chris McCormick Sep 8 '15 at 3:17
  • I'm Sorry to hear you had the same issue. Hope you didn't loose any data. Because Ubuntu wasn't starting correctly, to be able to log in and recover the data I did the following: When you start ubuntu start typing randomly. You don't even need to log in before Unity Desktop starts. This is enough for ubuntu to load, so you can save data. – A. Vieira Sep 8 '15 at 10:55
2

Update: WARNING - for some users such as @kalamalka-kid below, the following has broken their system settings completely. Proceed with caution.

I have some good news - I managed to get the "Low Energy" Bluetooth 4.0 Microsoft Designer Mouse working with my DELL XPS 13 laptop (broadcom bluetooth chip) reliably after 1.5 days of full time hacking and hair-tearing. Yay for Linux! :D

Documenting it here so somebody in the same situation doesn't have to go through the same hair-tearing.

First, I followed the instructions at the LTS Enablement stack page to get a nice new kernel 3.19 running on 14.04.

  • sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid
  • I also had to do apt-get dist-upgrade after that to actually install the new kernel packages.

This broke my Bluetooth completely because I have a Broadcom chip that requires custom firmware (see below for fixing that).

I uninstalled all of the Bluetooth stuff from my laptop to start fresh. The bluez package from the vidplace7/bluez5 PPA hung for me on uninstall. I fixed this by editing /var/lib/dpkg/info/bluez.prerm before doing the uninstall command and removing the invoke-rc.d line and replacing it with echo "no bluetooth stopping!". That worked and the package will uninstall with the following steps:

  • dpkg -l | grep blue will give you a list of all bluetooth packages.
  • apt-get remove --purge bluez bluetooth blueman... with all of those packages listed will uninstall everything.

Once all of the bluetooth packages are removed, remove the broken bluez PPA:

  • sudo add-apt-repository --remove ppa:vidplace7/bluez5

Then add the following PPA, which has a non-crashing version of bluez:

  • sudo apt-add-repository ppa:timchen119/bluez5-trusty
  • apt-get install bluez

Because the Dell XPS 13 has a broadcom chip it requires a custom firmware. The following firmware installation steps are only necessary for that chip. I detected the problem because of the following lines in my syslog:

kernel: bluetooth hci0: Direct firmware load for brcm/BCM20702A0-0a5c-216f.hcd failed with error -2
kernel: Bluetooth: hci0: BCM: patch brcm/BCM20702A0-0a5c-216f.hcd not found

So I had to follow these instructions to get the firmware installed again.

  • Get the driver from Microsoft here.
  • Open it with cabextract.
  • Convert the file and save to the firmware location: hex2hcd BCM20702A1_001.002.014.1443.1572.hex /lib/firmware/brcm/BCM20702A0-0a5c-216f.hcd - note that for the LTS kernel 3.19 only that version of the firmware will work. I tried a later version first and it did not work.
  • Make sure you power your laptop off and back on again don't just reboot.

Once you are up and running again bluetooth should work and you can install e.g. blueman to connect to the mouse. You can also manually connect to the mouse on the command line like this (first press the button underneath for 3 seconds to put it in pair mode):

# bluetoothctl 
[NEW] Controller XX:XX:XX:XX:XX:XX YourDevice [default]
[bluetooth]# agent KeyboardOnly 
Agent registered
[bluetooth]# default-agent 
Default agent request successful
[bluetooth]# scan on
Discovery started
[CHG] Controller XX:XX:XX:XX:XX:XX Discovering: yes
[NEW] Device YY:YY:YY:YY:YY:YY Designer Mouse
[bluetooth]# pair YY:YY:YY:YY:YY:YY
Attempting to pair with YY:YY:YY:YY:YY:YY
[CHG] Device YY:YY:YY:YY:YY:YY Connected: yes
[CHG] Device YY:YY:YY:YY:YY:YY Paired: yes
Pairing successful
[bluetooth]# connect YY:YY:YY:YY:YY:YY
[CHG] Device YY:YY:YY:YY:YY:YY Connected: yes

It took a long time to find out the issue with the bluetooth firmware because the only symptom was the messages org.bluez.Error.AuthenticationFailed and org.bluez.Error.AuthenticationCancelled when I tried to pair or connect.

  • Also, bluetooth was breaking after suspend. I fixed this by editing /etc/default/acpi-support to find the variabled called MODULES and added btusb to the list of modules to be reloaded. – Chris McCormick Oct 2 '15 at 0:47
  • Did you managed to get the keyboard working as well? This is where I'm struggling right now. I only get "Failed to connect: org.bluez.Error.Failed" using the bluetootctl when trying to connect to the keyboard. – lumen Feb 3 '16 at 17:59
  • 1
    Be very careful with this. I just tried installing bluez, i coulndt get it to work , so then I uninstalled it and now all my system settings programs are missing! BAD! – Kalamalka Kid Mar 11 '16 at 9:45
0

Thanks for your answers. This worked for me ...

. apt-add-repository ppa:vidplace7/bluez5
. apt-add-repository ppa:blueman/ppa
. apt-get update
. apt-get install bluez
. apt-get install blueman
. apt-get install bluez-compat

... but additionally I must run bluez in experimental mode. Replace /usr/sbin/bluetooth by your own script:

#!/bin/sh
bluetooth -E

Now I can connect with the blueman-applet mouse and keyboard.

Any ideas how to connect automatically on startup or without using blueman (just command line)?

  • Thanks. Seems it is pretty cumbersome to install this pig. Maybe this will help you. Can you please edit your post in order to be able to copy-paste the code into the console. In the first part it is required to add sudo in front -- this worked for me. The second part -- with the script -- did not worked, and i did not managed to find it. Thank you. – alex Mar 1 '16 at 11:25
  • 1
    I'm not allowed to answer so I add this comment. Just installed a Microsoft Bluetooth 3600 BLE mouse on Ubuntu (16.04). All I did was: sudo apt-get install blueman - sudo killall bluetoothd - and set it up with blueman-assistant. No need to add PPA. Hope it helps someone. – pizzamonster Apr 16 '16 at 13:54
0

I managed to kill my 14.04 laptop following very similar answers, so please beware when trying to "undo" any packages you installed here. Please don't remove the bluez package! (Only in hindsight do I realise this was a really really stupid thing to do.)

However, I did manage to get my keyboard and mouse to work really nicely in 16.04 and you can see my answer here: https://askubuntu.com/a/1023532/815371

protected by Community Feb 2 '16 at 23:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.