4

I am taking an online course that requires me to log in to a remote Windows server, and I am doing so using Remmina Remote Desktop Client. Once I am working on the remote server everything is fine, but if I switch to another application on my own computer, and switch back to Remmina, I can no longer type. The mouse still works to navigate the remote machine, and the keys work as shortcuts for some menu items, but I cannot type in any text areas. Control R seems to be bound to 'grab keyboard' on Remmina (I am not exactly sure what that means...), but pressing it does nothing. Every once in a while, and seemingly at random, I will regain the ability to type, but normally I have to quit Remmina and log in again. I am sure there is a simple solution to this, but I have not been able to find it so far.

I am using Remmina version 0.9.99.1, and Ubuntu 14.04. Thank you!

2
  • this is still an issue on Ubuntu 19.10; Remmina 1.4.3 git hash 688f5f75
    – caduceus
    May 4, 2020 at 9:23
  • I restarted Remmina, that solved it for me
    – Nathan
    Sep 20, 2021 at 6:29

2 Answers 2

1

I had this pop up again after upgrade from xubuntu 18.04 to 20.04. I am attaching an image of myenter image description here setting from remmina-preferences-rdp that fixed it for me. I don't understand why but the 100% setting and unchecking use client keyboard mapping fixed it for me in 18.04 and 20.04

1
  • Slightly different issue. Multiple RDP sessions deep I was losing all keystrokes except spacebar, delete and enter keys. This fixed that too! :)
    – pedwards
    Jan 5, 2021 at 17:17
0

I had the same problem with remmina(verion 1.4.2), I fixed it sending a hello world. Remmina has an option in Tools/Keystrokes/Send hello world after that the keyboard works very well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.