My computer booted to a black screen with this error message.

Welcome to emergency mode! After logging in,type "journalctl -xb" to view   
system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to   
try again to boot into default mode.

journalctl -xb snippet (what I think is wrong):

-- Unit systemd-fsckd.service has begun starting up.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1 contains a file system with errors, check forced.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1: Inodes that were part of a corrupted orphan linked list found.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: (i.e., without -a or -p options)
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: fsck failed with error code 4.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: Running request emergency.target/start/replace
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: systemd-fsck-root.service: main process exited, code=exited, status=1/FAILURE
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Failed to start File System Check on Root Device.
-- Subject: Unit systemd-fsck-root.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit systemd-fsck-root.service has failed.
-- The result is failed.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Unit systemd-fsck-root.service entered failed state.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: systemd-fsck-root.service failed.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Starting Remount Root and Kernel File Systems...
-- Subject: Unit systemd-remount-fs.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

I ignored other errors like: ACPI PCC probe failed, nvidia not proprietary, etc.

I can access my PC by pressing Ctrl+D , but it is annoying.

  • Here is a simple script you can run to apply the solution accepted above: github.com/trezcan/rpi-emergency-mode Commented Jun 10, 2016 at 9:23
  • Same problem here. Solution: I mounted an external HDD in fstab. In some moment I removed the ext HDD and this message appears. Just plug in the ext HDD and should boot fine. Or remove the fstab entry.
    – Savrige
    Commented Mar 24, 2020 at 9:56
  • For me the problem was combination of all answers. In particular the missing piece was that it was trying to boot from disk that was not connected... Root and home was fine. Very weird and I presume it was because I have wrongly reinstalled the system at some point and after not-used disk removal, it was not able to get up. Cannot add answer for some reason but commenting out UUID of boot in /etc/fstab resolved it. Commented May 1, 2022 at 19:15

16 Answers 16


You could run fsck from Ubuntu Live.

  1. Switch on your computer. Boot into a Ubuntu Live DVD/USB (try it without installing).
  2. After it loads, open a terminal by pressing Ctrl+Alt+T
  3. In the terminal, run:

    sudo -i
    fdisk -l

    fdisk will inform you what your partition / (root) is called. In this question it is /dev/sdb1.

    Then you should continue by running:

    umount /dev/sdb1
    fsck -y /dev/sdb1

    If the umount command complains that sdb1 is "not mounted", that is not a problem. We wanted it to be "not mounted" :).

  4. Remove the DVD/USB. Switch your computer on again, to boot from the SSD.

  • 1
    what about a flash drive, with ubuntu installed on it?
    – Kim André
    Commented Jul 9, 2015 at 14:58
  • 1
    I'l just try a flash drive with Ubuntu Gnome 15.04 on it.
    – Kim André
    Commented Jul 9, 2015 at 15:06
  • 1
    If only it is a testing device, it is best to recreate.
    – kyodake
    Commented Jul 9, 2015 at 15:11
  • 1
    yup that worked. tough i had to mount the SSD before i could umount it. hope i did id right. tough it worked anyways, but startup screen i see about 1 second is still messed up.
    – Kim André
    Commented Jul 9, 2015 at 15:17
  • 1
    Had the same issue in ubuntu 15.10. Applied the same solution.
    – kds
    Commented Nov 10, 2015 at 3:09

I don't know if u have solved your problem. What I did is :

sudo nano /etc/fstab

Then delete what you added there for sdb1 and then run:

sudo systemctl reboot

It says it's corrupted, so I don't know whats up about that, but I hope this could help someone who can't run their Linux.

  • 2
    I think this was the closest to my issue. I'd added something bad to fstab and couldn't figure out what it was. So cp /etf/fstab.orig /etc/fstab was my solution. Moral of the story: make a backup of your original fstab. Commented Dec 18, 2016 at 3:18
  • 1
    Your answer solver my issue. It looks like I had some entries about a swap area I never configured. So, I commented the last lines of the 'fstab' file. Then, I was able to return to my fresh installed system. Commented Feb 12, 2018 at 0:39
  • Best thing ever. and live usb needed. Just commented out stupid ntfs partitions
    – Ufos
    Commented May 20, 2019 at 15:25

I just had the case with Emergency mode. In my situation I followed an installation tutorial which suggested to edit some of the options for my mount points in /etc/fstab . By removing the extra options, my server rebooted without problems.

  • 9
    Welcome to AskUbuntu! It would be helpful if you could include a link to the tutorial you're referring to, or better yet, summarize the instructions within your answer.
    – user533208
    Commented May 10, 2016 at 12:20
  • 3
    Great suggestion. I had edited (and almost forgotten) my /etc/fstab by hand, priori to rebooting.
    – 0 _
    Commented May 14, 2016 at 3:55
  • 1
    You help me so much. Thank you +1
    – Benny
    Commented Aug 31, 2016 at 11:24
  • 1
    this is correct. I edited /media/ubuntu/MY_UBUNTU_PARTITION/etc/fstab and commented one extra line
    – Vahid
    Commented Feb 20, 2018 at 12:17
  • 1
    I was an idiot and mistakenly put in an fstab entry for a USB hard drive that of course wasn't plugged in :D so removing that fixed the problem for me Commented Jul 20, 2018 at 11:25

I am using Windows 10 and Ubuntu 16.X dual boot system.

I was not able to mount one of ntfs the partitions and the error was related to windows shutdown/hibernate. I used sudo ntfsfix /dev/sda3 to fix the issue. I was able to mount ntfs partition sda3 but on restart Ubuntu was starting in emergency mode.
To fix this issue, run the following command in windows

shutdown /s /t 5

This fixes Ubuntu emergency start issue.

  • 1
    Thanks, you led me to the solution! Windows does something very similar to hibernation by default when you shut down normally to enable the "fast boot" feature, so my solution was to turn off fast boot.
    – Ben
    Commented Jan 7, 2017 at 4:44

The answers by Khushboo Rani and Cagan Arslan led me to the permanent solution.

Windows 10 has a feature called fast boot enabled by default which, when the user shuts down normally using the "shut down" button or the power button on the computer, will actually save the running kernel and some other system stuff to the hard drive similar to hibernation after logging off. It also causes Windows to "lock" the partition in some way while doing this to prevent corruption of the data, accidental or malicious. This means Ubuntu cannot mount the Windows partition during startup.

In my case, I have entries for the Windows partition in /etc/fstab, so this made Ubuntu unbootable.

The solution is to boot into Windows, disable "fast boot", and then shut down normally. Now the problem should be solved permanently!

From the link I shared earlier, disable fast boot while in Windows as follows:

  1. Launch the control panel
  2. Go to the "Hardware and Sound" settings
  3. Go to "Power Options"
  4. Click "Choose what the power buttons do"
  5. Click "Change settings that are currently unavailable" and grant UAC access.
  6. Clear the checkbox by the "Turn on fast startup (recommended)" setting
  • 3
    For anybody dual-booting with Windows 10 and Ubuntu, Fast Boot ("Fast Startup") should be the first thing you disable. Thank you, this was exactly the issue I ran into.
    – Benjamin R
    Commented Jul 17, 2017 at 21:03
  • 2
    Just to note, even if you've done this before, you may have to do it again - updates to Win10 regularly mess with your settings. :-@
    – cooperised
    Commented Apr 23, 2018 at 7:26

In my case (Dual Boot Windows 10) i had to properly shut Windows down with the command (on windows):

shutdown /s /t 5

When i restart, Ubuntu loads without problem.


If this happens in a VirtualBox VM then it may be that it has failed to mount one of the partitions in /etc/fstab - unfortunately it fails with "welcome to emergency mode!" even if it's not a critical partition - for example if you've added a malformed entry to attempt to mount a filesystem using vboxsf then the whole system fails to boot without making it very clear in the boot log that this is the cause of the problem.

Anyway to clear the problem you need to either comment out the offending entry in /etc/fstab or modify it so that mount is happy with it.

  • I have one of my fstab entries as a USB drive that has a "Power Saving Mode" so every once in awhile it powers down. The mounting process doesn't wake it up, so it fails, falling back to emergency mode.
    – Jonathan
    Commented Oct 19, 2018 at 4:09

I've just had exactly the same problem, booting Ubuntu LTS 16.04 from a USB flash drive. Doing sysctl default did not fix it, fsck would flash shortly with scanning progress msg and then same prompt would come up. Here is what worked:

fsck -y /dev/sda1

Similar to some of the other answers, the trick for me was to comment out an entry in /etc/fstab for my optional LVM partition. I don't know why it started to complain a few days ago that Ubuntu 17.10 could no longer find the LVM partition, nor why this was causing the system to boot into "emergency" mode.

Once the entry was commented out in /etc/fstab, I rebooted successfully to my desktop. Looking at some tutorials, I noticed I was missing some LVM commands, so I ran sudo apt-get install lvm2 which seems to have fixed the problem.

If like me you think your LVM partition is the cause of the issue, the full set of commands I ran was:

sudo lvmdiskscan
sudo apt-get install lvm2
sudo lvmdiskscan
sudo lvdisplay
sudo vi /etc/fstab
sudo vgchange -a y
sudo mount -a

Not sure if all these are necessary -- I suspect that apt-get install lvm2 was key to getting my system to boot again.


So there are many good answers here - just to add to the info, my issue was a mistake in spelling tmpfs as tempfs which is incorrect in a line I added to /etc/fstab to secure a server


I had same problem , after running command fsck it was recovering but after some time my computer was going in emergency mode again so i removed whole data from my Hard disk and installed new OS. It solved my problem. I think so problem was with Ubuntu 15.0 vivid version so i installed 14.0 version. Still yet there is no problem.

  • This isn't really a "fix", but it does solve the problem at the cost of losing your data.
    – Tcll
    Commented Nov 6, 2017 at 2:25

I had the same issue. Commented manually added ntfs partitions from /etc/fstab System started normally. Used ntfsfix command to fix the journaling problem caused to those ntfs partitions Eg: Sudo ntfsfix /Dev/ntfs partition Mounted again in /etc/fstab Reboot


I just had the same issue and in my case, I had just recreated my grub partition and therefore it had a differente UUID than the last grub partition I had. When I booted ubuntu, the system wouldn't be able to check the UUID. To fix this problem I did:

sudo nano /etc/fstab

Then comment out the line containing the UUID from the partition I had just modified.

then reboot to apply changes.


All the above answers did not help me, as I didn't have a recovery file for fstab.
What did the trick was (in emergency mode)

cat /proc/mounts > /etc/fstab

I also came across same error showing (/dev/xyz) VFS: cant find ext4 filesystem.

I was not even having root user password for login.

So I following following steps to solve it,

  • Boot into a Ubuntu Live DVD/USB (Press F11 to select quick book option)
  • Recover root password using this method Reset root password for Ubuntu 16.04
  • Check file system status using following commands,

    df -h
    lsblk --fs --ascii 
    lsblk -l;
    fdisk -l;
  • Remove umount /dev/xyz volume and fix it using fsck / xfs_repair as per File system type.

umount /dev/sdb1 fsck -y /dev/xyz

  • In my case mount point was missing but fstab was having entry for it. So I created same mount point again and updated fstab entry using following commands.

sudo mkdir -p /mnt/abc sudo mount /dev/xyz /mnt/abc vim /etc/fstab UUID=xxxxxxxxxx-eeee-rrrrr-807a-xxxxxxxxxx /mnt/abc xfs rw,noatime 0 2

  • Then just reboot system.

sudo systemctl reboot

It worked for me.


In my case, I added a partition of a usb drive in /etc/fstab. when I booted with the usb drive removed, the error occurrd

all I needed to solve the issue is to remove the line about the usb drive. i know that you have resolved ur issue but this may be helpful for other people :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .