0

This question already has an answer here:

I am using Ubuntu 15.04 8u45-linux-x64.rpm and converting it to .deb using alien, then I am installing it using gdebi package installer.

now when I run a apt-get command I get this error

E: The package jre1.8.0-45 needs to be reinstalled

but I can't find an archive for it.

anyone help me?

Thanks

marked as duplicate by Eric Carvalho, Mitch Jul 10 '15 at 15:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • And why a RPM and not a DEB or the package manager? – A.B. Jul 9 '15 at 4:38
0

First, fix the apt-get error you're getting. Open a terminal (press Ctrl+Alt+T) and run:

sudo dpkg --remove --force-remove-reinstreq jre1.8.0-45

Once that's fixed, you should instead install it using WebUpd8's Oracle Java packages, which also automatically give you future updates when you do apt-get update.

To do so, open a terminal and run:

sudo -i
add-apt-repository ppa:webupd8team/java
apt-get update
apt-get install -y oracle-java8-installer

Not the answer you're looking for? Browse other questions tagged or ask your own question.