1

I'm using stock Ubuntu with Unity installed, and this problem is totally annoying.

In 12.04, Ctrl + Alt + 5 (Toggle Maximization State) would maximize/restore a window's state. E.g.:

  1. Open a terminal (which covers ~25% of the screen)
  2. Press Ctrl + Alt + 5 and it's maximized
  3. Press Ctrl + Alt + 5 again, and it's back to covering 25% of the screen.

In 14.04, pressing Ctrl + Alt + 5 the first time will maximize a window, but on the second time it will start toggling between maximized and full-screen (w/o menus). It won't ever restore the window's size to the non-maximized state.

I know there's another key that can do it (Ctrl + Super + Down = Restore Window), however, pressing this one twice will minimize the window entirely.

Is there a way to restore the behavior from 12.04?

1

Well, after installing Metacity (sudo apt-get install gnome-session-fallback), the behavior is as expected. From that I gather that the altered behavior is local to the Unity Launcher.

Don't think I can do much about it. But since I'm running inside a VirtualBox VM on a Win 8.1 system, and since Ubuntu 14.04 is way wayyy slower than 12.04 (especially with Unity Launcher), I think I'll stick with Metacity, which is a 2D display manager (as opposed to Unity Launcher or Gnome Compize, which are 3D and are killing the whole VM experience for me).

| improve this answer | |
0

Try the Unity Tweak tool; research if you think this add on addresses functionality. I also did something to change desktop appearance. Type desktop settings in search bar and customize to see if that can help.

| improve this answer | |
  • Thanks for the input. Unfortunately, I couldn't find anything relevant in unity-tweak-tool. – AVIDeveloper Jul 8 '15 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.