1

I have ubuntu 14.04 LTS installed, and after doing sudo apt-get update, sudo apt-get upgrade today a strange thing started happening.

After I open any application (or a terminal window), my mouse clicks don't work anymore. The only thing I can click on are the system icon in the top right corner of the screen (the dropdown with system settings, users etc.).

I have a Windows 8 dual boot, and the mouse works fine there so I'm pretty sure it's not a hardware problem. Regardless, I tried another mouse, and the same thing happens.

After finding this and this similar topics, I tried a couple of thing.

First thing I did was try compiz --replace, which makes my mouse work for a couple of seconds, then freezes up again.

I tried reinstalling inputattach, and all packages including the word mouse one by one, and nothing changed.

I tried removing (with purge) flashplugin-nonfree / flashplugin-installer, and nothing changed.

I tried writing gksudo gedit /usr/lib/nspluginwrapper/i386/linux/npviewer, upon which I get a strange error about mouse focus being taken away (gedit doesn't open). After running unity --replace, getid opened, and the line I was supposed to add (GDK_NATIVE_WINDOWS=1) was allready there.

When I run unity --replace, and login again, everything starts to work normally. I really don't won't to be doing this every time, firstly because it's annoying, but more importantly because ubuntu is my development environment, and I don't like knowing what's wrong.

So I tried reinstalling my ubuntu configuration. Guess what, I load the live demo to install ubuntu, and the same problem is there. Mouse doesn't work until I replace unity. So I left my current installation as is.

Any help you can offer at this point (been trying to wrap my head around this for 12 hours) is appreciated.

0

Have you been able to solve the Problem definitely? Or did it just vanish?

Currently I'm experiencing exactly the same Problem: After booting I can start exactly one application and few seconds later the mouse clicks do no longer work. Mouse movement and (sometimes) scrolling work fine. Mouse clicks in the dash work, but nowhere else.

And this Situation can be resolved with

CTRL-ALT T

unity --replace

But this is a tedious workaround.

The strange thing is: I had similar problems already quite often. Such problems occour randomly (presumably after an update) and vanish again a few weeks later (presumably after another update) but until now I have never been able to track them really down. Besides the obvious, that it has to do with compiz and unity or its predecessors.

I have the hardware in operation since 2011 and I had this situation about once a year, always with the up to date Ubuntu. At another place it seemed, that is has to do with the ASUS Motherboard. (I have a ASUS M4A87TD/USB3)

  • Nope, gave up after a day, installed ubuntu gnome, works great – Miha Šušteršič Jan 16 '16 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.