4

I'm using Ubuntu 14.04 and I'm trying to setup a few keyboard shortcuts for switching to specific workspaces, but the one for switching to #11 doesn't work.

The problem seems to be exclusive to workspace #11. For example I can set the shortcut for Switch to workspace 9 to Alt + 1 and it works fine, but when I set Switch to workspace 11 to Alt + 1, Ubuntu acts as if there wasn't a shortcut at all (eg. it activates Firefox's Alt + 1 shortcut of switching to the first tab)

Is there something I can do to correct this behavior, or is this a bug in Ubuntu?

0

I have no idea why this doesn't work, but I ran into the same problem myself and I have a workaround.

First, you need to find a command which lets you switch to workspace 11 (and in my case, also workspace 12)

Take a look at this answer to know how to do that.

For instance, on my system the command to switch to workspace 11 was wmctrl -o 3840,2160. This is resolution dependent, so I'd suggest looking at the original answer to find the command that reliably works for you.

Once you have the command, go to

System Settings > Keyboard > Shortcuts > Custom Shortcuts

And add these commands as custom shortcuts. Now assign any key to them and it should work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.