2

I'm having issues getting Crashplan remote GUI working correctly on my headless Ubuntu 14.04 servers. This is what I've tried so far;

Followed this guide to produce a SSH tunnel - http://support.code42.com/CrashPlan/Latest/Configuring/Using_CrashPlan_On_A_Headless_Computer

That didn't work. Just stalls on connecting and doesn't connect. I figured that it might be something to do with the SSH tunnel that might be wonky so tried a different approach and skipped the whole SSH tunnel (sincde I'm doing this on my own LAN) - http://www.liquidstate.net/how-to-manage-your-crashplan-server-remotely/

That still didn't work. I then tried several other things, such as firewalls (added ports to iptables) and changing ports up (besides 4200). Nothing worked.

I started to get the feeling that perhaps it was my Windows 10 preview that was the culprit so I started all over, installed the Crashplan app again on a different Ubuntu 14.04 server and the GUI on a Windows 7 laptop. Still the same issue regardless if doing it with SSH tunneling or not ....

I get the feeling that I'm missing something fairly obvious - could someone perhaps chime in about what it could perhaps be? I'm all for giving out logs and more information so troll me to a pulp if you want me to hand out more in order to resolve this. Trying to avoid installing x11 on all my servers...

Thanks in advance, Peter.

3

It seems Crashplan 4.3.0 changed headless authentication without updating the headless setup documentation, at least as of early July 2015. The client running the GUI interface now requires a matching GUID in C:\ProgramData\CrashPlan.ui_info for Windows.

The GUID can be obtained from the server using this command, run as root:

cat /var/lib/crashplan/.ui_info  ; echo

I found the information in this blog post helpful, particularly the last two steps: "Get the headless key from the .ui_info file" and "Update .ui_info on the computer connecting to Synology"

http://chrisnelson.ca/2015/07/02/fixing-crashplan-4-3-0-on-synology/

  • Also worth noting for Mac users is that the file cannot have a newline at the end (so copy the file rather than its contents) and that the ui.properties file has changed name and location to /Library/Application Support/CrashPlan/ui_username.properties (where username would originally have been determined by your home folder) – spume Jul 9 '15 at 13:41
  • I have such an array of mixed emotions right now. Part of me wants to go Hulk, smash on Crashplan for not even bothering to mentioning this on their website. But I'll stick with the happy and thankful emotions towards helpful members such as you two. You've certainly made my day! It works perfectly now. – Peter Jul 10 '15 at 7:31
0

Yes, the CrashPlan guys make quite a few changes without notification, I have started making a habit of saving all versions of the files I download from them as it's quite painful when they update. Have also started keeping the latest way to do this on my web site as it is hard to remember the file locations etc and it saves me looking them up all the time.

I have the whole procedure listed at the bottom of the article - link below.

https://www.tech-knowhow.com/2015/08/how-to-setup-crashplan-headless-on-ubuntu-linux/

Hope that helps and if you have any questions, please don't hesitate to ask.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.