1

I don't like getting online results when searching in my dashboard, so I went to System Settings > Security & Privacy > Search, and I turned the setting off:

Online search results setting off

But when I restart my machine, the setting is always reset to:

Online search results setting on

So how can I permanently disable it without it turning on again after a restart?

Information Update:

I have had a look at the post that this has been marked as a possible duplicate of, and I don't think that my question really is a duplicate of it, as the other question is asking about how to set it globally, and I am not, I am only wanting to set it for one user, so the fact that it is not global is not the problem, the problem is that it is not sticking for that one user, and just resetting to its default state after a restart. In fact, I don't want it to be set globally, and the answers from the other question only really explain how to do that.


OS Information:

Description:    Ubuntu 15.04
Release:    15.04

Package Information:

unity:
  Installed: 7.3.2+15.04.20150420-0ubuntu1
  Candidate: 7.3.2+15.04.20150420-0ubuntu1
  Version table:
 *** 7.3.2+15.04.20150420-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
  • you need to turn off scopes for online search ;) let me look if I got gconf I'll tell you more I just don't use unity anymore :( – JoKeR Jul 8 '15 at 11:49
  • Please let me know if you encounter any difficulties with the dupe. – Jacob Vlijm Jul 8 '15 at 11:51
  • also good thread askubuntu.com/questions/107701/… – JoKeR Jul 8 '15 at 11:57
  • also found my answer here askubuntu.com/questions/479363/… which I used in Unity to remove online search worked for me. ;) – JoKeR Jul 8 '15 at 12:01
  • @JacobVlijm: I don't want it globally off, I just want it off for one user, so I don't see how it is a dupe of that other question... – user364819 Jul 8 '15 at 12:03
2

You can switch off online search results with the command:

gsettings set com.canonical.Unity.Lenses remote-content-search 'none'

To make the command run on startup, and make sure it is set after a restart, add the following to your startup applications:

gsettings set com.canonical.Unity.Lenses remote-content-search 'none'
  • Why does it set back to its defaults anyway, is this some sort of bug? Because I wouldn't think that it would be by design that you would set a setting one way, and then after a restart, it would just set back... – user364819 Jul 8 '15 at 12:16
  • If gsettings stick after a restart is unpredictable, especially on lenses. I suppose they should stick, but often they don't. Adding it to startup applications is then a usable workaround :) – Jacob Vlijm Jul 8 '15 at 12:19
  • Probably a problem with Ubuntu 15.04 since it's not an LTS version, therefore not as free of bugs as an LTS version. I know that it used to work and that there are other bugs in 15.04 as well, which didn't use to exist in Ubuntu. – UTF-8 Jul 8 '15 at 12:21
  • @UTF-8: Which package would I report this bug to? – user364819 Jul 8 '15 at 12:26
  • 1
    It's fine, I figured it out... – user364819 Jul 8 '15 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy