1

I am installing pothosware but the following error occurs:

cc1plus: error: unrecognized command line option ‘-std=c++11’

I am trying to install through synaptic package manager .

closed as unclear what you're asking by muru, Tim, Pilot6, Eric Carvalho, waltinator Jul 12 '15 at 4:20

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I'm confused: I didn't think installations via synaptic should require compilation from source code. Anyhow please edit your question to include the Ubuntu version (and g++ version, if you know it): the c++11 flag is a recent addition to g++ – steeldriver Jul 8 '15 at 11:42
1

Very short answer, sorry.

To use the -std=c++11 option you need at least gcc-4.7.


Check your version with

apt-cache policy gcc
  • Hi A.B I have installed gcc-4.8 Now error is gone. Thanks for help... – Mushir Jul 13 '15 at 8:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.