4

I have the Numix icons package on PPA on Kubuntu 14.10.

That has been working fine, but a week or so ago an update came through, it installs and says complete I run sudo apt-get update and sudo apt-get upgrade that day and there are no updates available, but the next day it update appears back again.

I haven't been able to find anyone else with the same package problem, i.e. I don't think it is package related or there would be others with same issue.

Preparing to unpack .../numix-icon-theme_0.3+478~201507080101~ubuntu14.10.1_all.deb ...
Unpacking numix-icon-theme (0.3+478~201507080101~ubuntu14.10.1) over (0.3+476~201507070101~ubuntu14.10.1) ... 

I did try one thing delete the cache in /var/cache/apt/archives - but it didn't work and the post was slightly unrelated, will try again - if directed to correct cache file to delete?

I tried :

sudo apt-mark unhold package_name  

which didn't work, the package isn't held.
then after searching tried :

sudo apt-get -f install

sudo dpkg --configure -a

Need to wait till tommorrow ?? ....

It is not the october 2014 change to the PPA as it has been working normally till July 2015.

5
  • what is the output for: apt-cache policy numix-icon-theme? – JoKeR Jul 8 '15 at 11:34
  • 1
    possible duplicate of why numix icon theme get updates almost everyday? – Sylvain Pineau Jul 8 '15 at 11:35
  • You should get ready to upgrade to 15.04. 14.10 will be dead before the end of the month. – Oli Jul 8 '15 at 11:42
  • numix-icon-theme: ** Installed: 0.3+478~201507080101~ubuntu14.10.1 Candidate: 0.3+478~201507080101~ubuntu14.10.1 Version table: *** 0.3+478~201507080101~ubuntu14.10.1 0 500 ppa.launchpad.net/numix/ppa/ubuntu utopic/main amd64 Packages 100 /var/lib/dpkg/status – wrapper Jul 8 '15 at 12:50
  • Upgraded to 15.04, now I can't access my camera – wrapper Jul 10 '15 at 14:23
3

Look at the version numbers it says it's downloading to replace:

0.3+478~201507080101~ubuntu14.10.1
0.3+476~201507070101~ubuntu14.10.1

They are different. And looking at the full version, they look like nightlies (both built at 1:01 AM).

I suspect that if you look at apt-cache policy numix-icon-theme, you'll see you're getting it from a daily/nightly -style PPA, which tracks a development version control system and automatically recompiles the packages, regardless of change.

To stop this, either:

0

Maybe you have the package on hold. From this post, try to remove the hold of the package you want using

sudo apt-mark unhold package_name

4
  • It installs every day, so I didn't think it was that, muon says it is not held but incase : sudo apt-mark unhold numix-icon-theme numix-icon-theme was already not hold. – wrapper Jul 8 '15 at 11:13
  • does the installation of the package complete successfully? – Kiriazis Kokkinos Jul 8 '15 at 11:15
  • Sorry problems learning formating How do you line break??? – wrapper Jul 8 '15 at 11:18
  • In Muon it says the "new"package version is installed but the "new" version is available for download (as an update) (I assume that means there is a config glitch)... No others programs are marked the same, so it is supposed to be installed.... – wrapper Jul 8 '15 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.