1

I updated to 14.04 by reinstalling over the old 12.04 install.

After using the system for a few weeks I log in one day and there is no desktop / unity at all. Just a background and mouse pointer. The guest session logs in fine.

I've tried various posts (Problems after upgrading to 14.04 (only background and pointer after login)) etc but it seems I'm shooting in the dark...

In the syslog there are errors about compiz.desktop killed by signal 9 and respawning too quickly but I can't see any fixes for my case.

I should add that a guest session logs in fine and the unity desktop displays as per normal...

Can anyone shed any light on this?

Thanks,

Adam

  • Did you update or reinstall? – Karl Richter Jul 8 '15 at 9:13
  • Long story...initially I updated from 12.04 to 14.04 but that completely broke the system. So I reinstalled via a USB stick. That worked okay as I just recreated the same user so didn't lose anything. That was 3-4 weeks before the blank screen problem I'm posting about here. Logged in one day and no desktop just a mouse pointer. The below commands have fixed it but of course the settings I had are gone. If it happens again I will try and trace it to a more specific folder. – Adam Rifat Jul 8 '15 at 9:59
1

Something corrupted...

sudo rm -rf ~/.config

sudo rm -rf ~/.cache

...seems to sort it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.