1

How to enable multitouch for touchpad and touchscreen? I'm using Ubuntu 15.04 Vivid Vervet on a Lenovo ThinkPad X1 Carbon 3rd gen (Touch) 2015.

What does work:

  • Fn+ buttons works out of the box – screen brightness, mute, volume adjustments, mic switch, Wi-Fi switch;
  • TrackPoint with mouse buttons;
  • Touchpad with 2 fingers multitouch (except pinch-to-zoom);
  • Suspend;
  • Keyboard backlight with 2 grades of intensity;
  • WiFi, Bluetooth, WLAN;
  • Touchscreen (multitouch doesn't work);
  • Fingerprint reader.

What doesn't work:

  • Touchpad multitouch with 3+ fingers;
  • Touchscreen multitouch with 2+ fingers.
1

Touchegg works for me -- however apparently not on Firefox or Chrome, only on Chromium, do the multi-touch gestures work for me (out-of-the-box).

On Chromium, I can one-finger drag (on-screen touch, not touchpad), two finger scroll (touchpad), pinch and zoom (on-screen touch).

See: Firefox bug, https://askubuntu.com/a/664898/67349

To fix chrome, I had to follow both answers at Chrome + Touchscreen + Unity (14.04)

First,

  • Navigate to chrome://flags/#touch-events and
  • set Enable touch events Mac, Windows, Linux, Chrome OS to enabled.
  • I also set "Enable pinch scale. Windows, Linux, Chrome OS" to enabled (instead of default).

Second, I needed to start google chrome and tell it which device.

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ ELAN Touchscreen                          id=9    [slave  pointer  (2)]
$ google chrome --touch-devices=2

My Setup

  • ubuntu 14.04
  • lenovo 2nd gen x1.
  • Chromium: Version 43.0.2357.130 Ubuntu 14.04 (64-bit)
  • Chrome: Version 43.0.2357.134 (64-bit)
  • Firefox: 40.0

My ~/.config/touchegg/touchegg.conf if it's useful: http://pastebin.com/qGexA1gB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.