1

When i try to install mysql by this command on ubuntu 14.04 i get this error. Help me with simple and detailed solution as I am new on ubuntu.

sudo apt-get install mysql-server

Error:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-server : Depends: mysql-community-server (= 5.6.25-3ubuntu15.04) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
0
0

You can try a clean uninstall of all that is related to mysql.

sudo apt-get purge mysql-community-server mysql-server

And then reinstall the mysql-server. If that does not work, try to do a search for mysql using apt:

apt-cache search mysql

And try to install another version for mysql-server and mysql-client.

2

Not the answer you're looking for? Browse other questions tagged or ask your own question.