0

How do I run this command on splitting files, but with re-encoding to MP4 as shown in earlier post?

And when splitting the file, how do I avoid hogging the system's resources (especially if it's a large file)?

4
  • How do I review the edits? Thanks for the correction! – Dominic Isaiah Jul 9 '15 at 15:02
  • what version of ubuntu are you using – mchid Jul 13 '15 at 6:10
  • Its Ubuntu 15.04 – Dominic Isaiah Jul 13 '15 at 6:22
  • The question you linked to, is about splitting withOUT re-encoding. If the source file is in a non-MP4 format, FFMPEG will re-encode the segments to MP4. If the source file is in MP4, there is no reason to re-encode, you just copy the streams. Besides, re-encoding is exactly what hogs systems resources, so to avoid that, you do a stream copy. – theodorn Feb 22 '16 at 0:07
1

Use the -threads 1 flag to limit ffmpeg use to a single thread only

to use that with the command from the other post:

ffmpeg -i ~/Desktop/in.mp4 -threads 1 -codec copy -map 0 -f segment -segment_time 15 -segment_format_options movflags=+faststart out%03d.mp4
3
  • Thanks! Kindly help with the first question which hasn't been answered yet. – Dominic Isaiah Jul 13 '15 at 6:01
  • @DominicIsaiah I see you had some errors during playback after running this command on your file. If you post the errors, we can probably figure out what is wrong. You can post the errors by editing your original post askubuntu.com/questions/640214/… and adding the errors to your question. Thanks! – mchid Jul 13 '15 at 20:16
  • I could not see any error messages. But some of clips played fine, while some did not play. I used vlc. The default player, I think which is totem us used to freeze. – Dominic Isaiah Jul 15 '15 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.