I've been trying to upgrade from 10.04 to 10.10.

During the package installing and upgrade process there were numerous packages which threw errors but it continued installing. The last one to fail was squid, when this failed the upgrade manager quit-out without finishing everything. When I restarted I get a Kernel Panic error:

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Pid: 1, comm: swapper Not tainted 2.6.35-22-generic #33-Ubuntu

Similar to the question asked here.

At the grub loader I tried to boot to 2.5.32 but this drops into an incomplete command-line (BusyBox) with limited commands with the error: udevadmn trigger is not permitted while udev is unconfigured

Any help would be greatly appreciated.

  • If the question is a duplicate, then you shouldn't ask it again, rather go to the original question and provide details of your own experiences there. – user2405 Oct 12 '10 at 15:52
  • its not a duplicate since my issue cannot be resolved by any answers that are there. The OP of the other question seemed to be able to drop into a CLI but I cannot. – JudoWill Oct 12 '10 at 15:59
  • Ah, fair enough. – user2405 Oct 12 '10 at 23:20

I'm not sure if this will help anyone else but this is the process I had to go through ... and my thoughts as to why:

  1. Backup all data
  2. Unplug my external drive
  3. Re-install a fresh 10.10
  4. Copy data back

Every time I tried to install 10.10 with my external drive plugged in it would choose the external drive as the default install location. I would change it to my internal drive and then install as normal. However, after re-boot it would have the issues mentioned above. On a lark I tried installing after unplugging the drive. Everything worked out fine.

Thanks for the help everyone and I hope that this answer helps someone else.

| improve this answer | |

If you're familiar with the command line, you can use an Ubuntu Live CD, open a terminal and chroot into your system in order to finish the upgrade. More or less, the commands you'll have to type are the following:

sudo mount /dev/your-root-partition /somewhere
sudo chroot /somewhere
dpkg --configure -a
| improve this answer | |

If you've got a separate home partition, I would suggest you reinstall Ubuntu over the current root partition.

Make sure you get your mount points correct (don't forget to make sure that /home/ is not going to get formatted) and if you've got multiple users, don't change the order of the users (ensure the person whose home dir is owned by 1000 is added as admin, then add the person whose directory is owned by 1001, etc).

I've often had trouble upgrading from one version to another and prefer fresh installs to upgrades. Also when things go this bad, there are probably too many problems that you will need to fix (if at all they can be fixed) before you get your system work as you'd like it too.

If you have some valuable information about this problem, I would suggest reporting a bug.

| improve this answer | |

I'm afraid that the simplest way is to copy /home directory to external drive and reinstall system.

I also recommend separate partition for /home dir. The most critical time in upgrade is when package manager has downloaded all files and before finish of configuration. When You have error there that's very bad situation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.