0

First time installing Ubuntu. I have followed the instructions here, with the difference that:

  • I had already used Windows to create 3 partitions for Ubuntu.
  • This line in step 7 did not work: sudo apt-get install -y boot-repair && boot-repair so I ran a different pair of commands (possibly sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update then sudo apt-get install -y boot-repair && boot-repair) which did work.

Here's the output:

http://paste.ubuntu.com/11833014/

After rebooting into Windows 8.1, I ran the command...

bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi

... using the admin command prompt, and was told that it succeeded. However, when I reboot into Ubuntu using my Live USB stick, I see that there is a volume called SONYSYS with total capacity of 268.4 MB, which contains this file \EFI\ubuntu\shimx64.efi but no file called grubx64.efi (but perhaps I am looking in the wrong place). This volume also contains folders named BOOT and WINDOWS.

Can you recommend solutions that I can try?

Note: Windows 8 Fast Startup is switched off, is is Secure Boot. Changing the admin propmt command to bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi, as suggested here did not solve the problem.

0

First, a partition called SONYSYS suggests you've got a Sony. Unfortunately, many Sonys are known to have flaky EFIs, so you may be in for a fight. If the computer is new enough and you get even remotely frustrated by this, I STRONGLY urge you to return the computer to the store for a refund, then write to Sony to tell them you returned the machine because it was defective, with details. Manufacturers will continue to sell junk until they feel the pain (in the form of the costs of returned machines) of doing so. Unfortunately, far too many people roll over and jump through ridiculous hoops to avoid returning defective merchandise.

Second, it appears that your /dev/sda3 is your EFI System Partition (ESP), but your computer also has an ESP-like partition on /dev/sda1. It's unclear which of those two partitions holds the boot loader that actually boots Windows, but it looks like Ubuntu installed GRUB to /dev/sda3. I don't know enough about bcdedit to know whether it would modify the boot configuration to point to files on /dev/sda1 or /dev/sda3 in your case, so it's possible that this is the problem. You could work around this by mounting both partitions and copying the EFI/ubuntu directory from /dev/sda3 to /dev/sda1, then booting back to Windows and trying with bcdedit again.

Another option, if you haven't invested too much time in configuring Windows, is to re-install a stock version of Windows, rather than the Sony-customized version that's probably to blame for the sda1/sda3 shenanigans, and perhaps other idiosyncracies. Fortunately, you can download Windows media legally, as described here, among other places. This re-installation might simplify and regularize things enough to help cut through the problems.

If all of this fails, the easiest remaining option (other than returning the computer) is to engage in some ugly hacks that involve renaming the Windows boot loader and copying GRUB (or some other Linux-ready boot loader) in its place. The Boot Repair tool can do this. The option is on the Advanced menu and refers to backing up and renaming EFI boot files. (I don't recall the precise phrasing.)

  • Thanks for your grim diagnosis Rod. It's not my computer, and it's not new, and I don't want to fight with Windows too, so I'm going to have to take the "ugly hack" root. I've posted a new question, so that I can move forward one baby step at a time. – James Newton Jul 7 '15 at 16:34
  • The local computer recycling organization has a Sony Vaio laptop with 75 GB hard disk and 1 GB RAM, at a very affordable price. If I install Ubuntu as the only system on this laptop (on a freshly-reformatted drive), would this mean that I avoid all the Sony customization issues that you mention? Or do you recommend avoiding Sony altogether, even for a single-boot Ubuntu system? – James Newton Jul 7 '15 at 17:18
  • A computer with the specs you note probably pre-dates common use of UEFI in PCs. (They started to become common in new computers in mid-2011.) I'm reluctant to say "avoid all Sonys" because of EFI issues, but at the very least, you do need to be aware of the possibility of problems. ASUS and Dell seem to have decent EFIs. So do most Lenovos. Sony and HP seem to be the models with the most problems, based on problem reports I see online. – Rod Smith Jul 7 '15 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.