1

There is one specific coffee shop WiFi network that I cannot connect to (doesn't even show up in the available networks listing) on my Ubuntu 14.04 laptop. I had previously connected to this WiFi network many times, and I can easily/reliably connect to the network using my iPhone or Mac laptop. My Ubuntu 14.04 laptop can find/connect to other WiFi networks (including the one I'm connected to now) no problem. I did a fresh install of Ubuntu 14.04 a few days ago due to an unrelated problem. Finding the WiFi network became an issue after that.

I have tried the related solutions listed below without success:

  1. Can't connect to a specific WiFi network (Ubuntu 14.04)

  2. Can't connect to specific wifi network

  3. WIFI not working on one specific wifi network

If I run the command:

sudo lshw -c network

I get output as follows (apologies for the odd formatting):

*-network description: Ethernet interface

 product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
  vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: eth0
   version: 07
   serial: 20:1a:06:5e:a1:c6
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:48 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

*-network description: Wireless interface

  product: RTL8188EE Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 01
   serial: 34:23:87:1d:f3:1b
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8188ee driverversion=3.16.0-41-generic firmware=N/A ip=192.168.0.19 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 ioport:1000(size=256) memory:f0200000-f0203fff

Any ideas appreciated. Thanks.

7

I have the same problem with my Dell laptop version of the broadcom wireless adapter. After a few hours searching and trying various stuff (including destroying my wlan driver so I had no wifi at all :) I found out that the wl kernel driver does not support wifi channels above 11 (!). The b43 driver was no option for me since it does not support by my hardware device (trying this "wrecked" my wifi and I had to re-install the broadcom driver).

The workaround I did was to log in to my wireless router and tell it to use a channel from the range 1-11 (e.g. channel 7) and voila, I could now see my SSID in Network Manager applet again!

Of course, to do this you need to have access to the wifi router configuration, i.e. this may not be applicable to public places (coffe shops, airports, workplaces,...). If you can't access the wifi router, then you just have to wait until it uses channel from range 1-11 again...

  • Can you link to a source for your assertion that the kernel driver doesn't support channels > 11? – Aaron Hall Feb 24 '17 at 1:24
  • Thank you for this answer, in my case my wifi was showing in my ubuntu for past 7 days and was working fine but then all of sudden it was not showing in list. So I simply went to the router settings and I found that channel settings was in 'auto' so I changed it to 1 and restart my router and now it is working fine. – Shashank Jun 18 '18 at 15:23
  • I thought might be this reason but was hoping not 😂 Im also on a Dell inspiron – Ardit Meti Oct 26 '18 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.