0

I am running ubuntu 14.04 and just installed 2GB of ram in addition to the 4GB I already have. However when I look under about computer it show me only having 2.7 . when I run "sudo lshw -class memory" it clearly shows that I have 2x 2GB sticks and 2x 1GB sticks. What is going on?

  *-firmware              
       description: BIOS
       vendor: Dell Inc.
       physical id: 0
       version: 1.0.5
       date: 09/14/2007
       size: 128KiB
       capacity: 1984KiB
       capabilities: isa pci pnp apm upgrade shadowing cdboot bootselect socketedrom edd int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification netboot
  *-cache
       description: L1 cache
       physical id: a
       slot: Internal Cache
       size: 32KiB
       capacity: 32KiB
       capabilities: synchronous internal write-back
  *-memory
       description: System Memory
       physical id: 24
       slot: System board or motherboard
       size: 6GiB
     *-bank:0
          description: DIMM DDR2 Synchronous 667 MHz (1.5 ns)
          product: M3 78T2863RZS-CF7
          vendor: Samsung
          physical id: 0
          serial: 64869EF2
          slot: DIMM1
          size: 1GiB
          width: 64 bits
          clock: 667MHz (1.5ns)
     *-bank:1
          description: DIMM DDR2 Synchronous 667 MHz (1.5 ns)
          product: NT2GT64U8HD0BY-3C
          vendor: Nanya Technology
          physical id: 1
          serial: B74E3E3B
          slot: DIMM2
          size: 2GiB
          width: 64 bits
          clock: 667MHz (1.5ns)
     *-bank:2
          description: DIMM DDR2 Synchronous 667 MHz (1.5 ns)
          product: M3 78T2863RZS-CF7
          vendor: Samsung
          physical id: 2
          serial: 64869EF8
          slot: DIMM3
          size: 1GiB
          width: 64 bits
          clock: 667MHz (1.5ns)
     *-bank:3
          description: DIMM DDR2 Synchronous 667 MHz (1.5 ns)
          product: NT2GT64U8HD0BY-3C
          vendor: Nanya Technology
          physical id: 3
          serial: 874E3E3B
          slot: DIMM4
          size: 2GiB
          width: 64 bits
          clock: 667MHz (1.5ns)

Edit:

Here is my kern.log. I will add the other stuff when I get home.

Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] e820: BIOS-provided physical RAM map:
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009ebff] usable
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x000000000009ec00-0x000000000009ffff] reserved
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000000f0000-0x00000000000fffff] reserved
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x0000000000100000-0x00000000afe8ffff] usable
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000afe90000-0x00000000afee2fff] ACPI NVS
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000afee3000-0x00000000afeeffff] ACPI data
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000afef0000-0x00000000afefffff] reserved
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000e0000000-0x00000000efffffff] reserved
Dec 31 19:00:53 mag-downstairs-linux kernel: [    0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000ffffffff] reserved
  • If you go to bios, what does it show regarding RAM size? – Pilot6 Jul 6 '15 at 19:47
  • Might it be that your SODIMMS might be laid out as 2x1GiB and 2x2GiB (rank 2 memory, or effectively two memory setups per DIMM). As for the 2.7... As Pilot already write: Check the BIOS first. If that sees the full 6GiB then check if you are running a normal 64 bit setup and not some 32bit-without-PEA. – Hennes Jul 6 '15 at 19:59
  • Look through your dmesg or /var/log/kern.log for the bios e820 section and add that. – psusi Jul 6 '15 at 21:46
  • Are you sure that your video card isn't getting memory from the RAM? – aastefanov Jul 8 '15 at 17:00
  • I have a dedicated video card with 4GiB of ram so it should not be getting any memory from my ram – maglax Jul 9 '15 at 2:21
0

You may need to switch the cards. Right now you have the 1GB cards on bank0 and bank2, with the 2GB cards on bank1 and bank3.

Check with your manufacturer. According to

http://h20331.www2.hp.com/Hpsub/downloads/Mini_WP_Z800_memory.pdf

and

https://superuser.com/a/107753/317065

You may need to put the two 2GB cards on bank0 and bank2 instead.


Alternatively, according to here there may be a BIOS setting under chipset configuration > internal graphics for frame buffer location. In that post, the user changed the setting from above 4GB to below 4GB and problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.