I have purchased a new HP Pavilion 15-ab030TX, just installed dual boot Ubuntu 14.04 next to Win8. But my wifi has been showing either very weak signal at times or none at all. I tried multiple solutions available on internet but nothing seems to work. Also i hosted connectify on another laptop and started using internet through that it worked for two days but it is also not connecting (probably due to trying some solution from old posts).

  • Which solutions did you try?
    – Pilot6
    Commented Jul 6, 2015 at 19:45
  • I tried askubuntu.com/questions/389268/… solution from chili555
    – pradex
    Commented Jul 6, 2015 at 20:02
  • I think you upgraded the kernel and the driver stopped working. I will answer how to install same driver permanently.
    – Pilot6
    Commented Jul 6, 2015 at 20:04

3 Answers 3


You need to install the driver using dkms. If you build it from the lwfinger git, it stops working after kernel upgrades.

I packed the same driver as DKMS and added it to a ppa. Install it this way:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware

and reboot.

  • This seems to have worked for me, I will keep an eye on my system for next 24 hours before marking this as Solved. Thanks a ton for your help. :)
    – pradex
    Commented Jul 6, 2015 at 20:38
  • worked for me as well. Ubuntu 16.04 on HP 470 G3 here. Thanks, mate.
    – kmonsoor
    Commented Oct 24, 2016 at 10:05
  • @Pilot6 I got a HP pavilion x360 (laptop with touch screen). I was trying to install 16.10 (after clearing windows 10 which came per-installed)and followed your instruction. But still it is not working. Can you please help?
    – RSG
    Commented Nov 23, 2016 at 5:13
  • This PPA does not work for 16.10.
    – Pilot6
    Commented Nov 23, 2016 at 8:14
  • Error! Bad return status for module build on kernel: 4.10.0-38-generic (x86_64) Consult /var/lib/dkms/rtlwifi-new/0.10/build/make.log for more information. Commented Nov 1, 2017 at 15:43

Quite often, the weak signal is a symptom of the antenna wire being connected to connection #1 on the card when the default driver is expecting to see the signal at connection #2. Of course, you could open the laptop and switch the wire or you could install a newer driver that permits antenna selection at the driver level.

Please obtain a temporary ethernet connection by ethernet, tethered or whatever means possible. Open a terminal and do:

wget https://github.com/lwfinger/rtlwifi_new/archive/rock.new_btcoex.zip
unzip rock.new_btcoex.zip
cd rtlwifi_new-rock.new_btcoex
sudo -i
make install
echo "options rtl8723be ant_sel=2"  >  /etc/modprobe.d/rtl8723be.conf


Whenever Update Manager installs a later kernel version, also known as linux-image, after the requested restart, you must recompile:

cd rtlwifi_new-rock.new_btcoex
make clean
sudo make install

Reboot and your wireless should be working.

  • 1
    Why not make a dkms?
    – Pilot6
    Commented Feb 4, 2016 at 15:53
  • 2
    I made DKMS and added to my repository askubuntu.com/a/635629/167850
    – Pilot6
    Commented Feb 6, 2016 at 10:22
  • Sorry, i didn't understand: if the default driver expects the antenna at connection #2, why to add ant_sel=2? Isn't it what it expects then?
    – Alexey
    Commented Feb 15, 2018 at 7:13
  • The default driver is unable to autodetect where the antenna is connected at all. If you have weak signal, tell the driver to try the other antenna connector; it is most often, but not always #2. @Alexey
    – chili555
    Commented Feb 15, 2018 at 13:18

Upgrade your Linux Firmware to 1.161 and Kernel version to 4.8.

To update the Linux Firmware , there are two ways :-

    1.  Via Ubuntu Software Center:
           Download this file -

    Then open this Debian Package with Ubuntu Software Center and click    Install

2.Via Terminal : Open The Terminal ( ctrl+alt+T) Enter :-

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161_all.deb

        De-package it :-

sudo dpkg -i linux-firmware_1.161_all.deb

Now check your kernel version :-

Type:- uname -r
    Note if its generic or cloud or low latency

Upgrade your kernel to 4.8:

Go to Index of /~kernel-ppa/mainline/v4.8
For 64 bit system look under the amd64, for 32 bit one look under i386
For example, if its amd64 and your kernel is generic download these 3 files:-


Now Open these files one by one in Ubuntu Software Center and install all the three.
Check again for your kernel version Type:- uname -r
It’s 4.8 and your WiFi should be working !!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .