4

I have been following this linode tutorial

Except that I want to use Xfce instead of Unity.

On the last line of the ~/.vnc/xstartup file is says to add:

gnome-session &

What should I put for Xfce?

6

Normally to start the Xfce session from the console, you should put:

xfce4-session

More here, but I'm not sure about using this with VNC. Remember that first you have to install Xfce, in first step from Your link (Installing a Desktop and VNC on your Linode) change:

sudo apt-get install ubuntu-desktop

to:

sudo apt-get install xfce4
  • @frlan: Could you please review my edits and also review the spelling and grammar of the questions or answers you're editing in the future? As now you're creating additional work for the reviewers instead of less work... ;-) – Fabby Jul 8 '15 at 8:21
1

After installing tightvnserver and xfce4 (apt-get on ubi) run "vncserver" once to create ~/.vnc/xstartup file. move it, and create a new xstartup file and put this in it.

#!/bin/bash
xrdb $HOME/.Xresources
startxfce4 &

Save it, kill the running one (should be :1 - cmd = vncserver -kill :1) and the restart it .. when you connect with vnc client (:1 = 5901, :2, 5902, etc) you should have xfce4 startup (dont forget xfce4-goodies package)

There's a nice write-up at DigitalOcean website here.

  • I'm following DigitalOcean's guide but found no option to save the file, how to save it? – Niminim Jun 3 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.