2

I have certain apps which I want to be on top (I set it via window's menu: Alt-Space + "Always on top"). But when I switch between apps by pressing Alt-Tab once, these windows steal focus. This happens when I close active window also. Is there a way to make window un-focusable to prevent this? I tried to solve this via ccsm: General options/Focus & Raise behavior/Focus Prevention Windows but without luck.

1 Answer 1

1

One way to go, is to tell window switcher to ignore it.

  1. Install ccsm& run it
  2. Desktop category → Ubuntu Unity plugin → Switcher tab

    Disable all its shortcuts.

  3. Enable alternative switcher

    Window management category → Application switcher

    • Check enable application switcher
    • General tab → change Switcher windows to exclude your specific windows.

      Example for gnome-terminal:

      (Toolbar | Utility | Dialog | Normal | Unknown) & !(name=gnome-terminal-server)
      

You could even use dual switcher:

  • Set AltTab & ShiftAltTab for application switcher
  • and live set AltCtrlTab & ShiftAltCtrlTab for unity switcher

So current desktop window switcher will skip it but the all window switcher will not. Best of both worlds

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .