8

I have recently upgraded to Ubuntu 14.04 LTS 64-bit. I had this configuration working for three years with Ubuntu 12.04 LTS. I went for a fresh installation (not distro upgrade), the only thing I kept are the home folders (/home mountpoint) of my users. Scenario:

  1. I can access my wi-fi network
  2. I can stream music via bluetooth with A2DP

If I try to do both at the same time now, e.g stream audio from deezer, the internet connection stops. I can't even ping google.com; so I think this is not a browser related issue. If I switch-off the bluetooth everything gets back to normal. I've got no clue on where to start debugging my problem.

Here the output of lspci -knn | grep Net -A2; lsusb

03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34) Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5305] Kernel driver in use: iwlwifi
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 001 Device 004: ID 1bcf:2883 Sunplus Innovation Technology Inc. 
Bus 001 Device 003: ID 8086:0189 Intel Corp.  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command. – Pilot6 Jul 6 '15 at 9:08
  • Pilot6 I played further with it this morning, and seems that I managed to get something working more stably when installing blueman for xfce. In fact with the new installation I'm also evaluating the possibility to migrate desktop manager. But this is another story. The overall behaviour of bluetooth is still a bit obscure, and far from being reproducible, but I made a step forward. – Andrea Borga Jul 6 '15 at 11:55
15

You can fix it by turning off bluetooth and wireless coexistence.

Run in terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi bt_coex_active=N"

and reboot.

It looks like kernel developers have overdone that functionality slightly ;-)

This setting can be always undone by

sudo rm /etc/modprobe.d/iwlwifi-opt.conf

You can read this to understand what it does

| improve this answer | |
  • Great!:) that fixed it indeed. Thanks for the informative link as well, I'll read further about bluetooth-coexistence. I'm interested in low level software and hardware in general. – Andrea Borga Jul 6 '15 at 21:03
  • @guntbert I amended commands to make a separate file. – Pilot6 Aug 26 '15 at 20:09
  • @guntbert By testing – Pilot6 Aug 27 '15 at 20:56
  • 1
    It didn't fix mine. multiple key strokes for a single stroke :( – Necktwi May 27 '17 at 5:58
  • 1
    Worked for me on 18.04.1 LTS. – Kamil Maciorowski Sep 12 '18 at 18:37
4

Run the following command:

echo "options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi-options.conf > /dev/null

It worked for my ubuntu 16.04 like a charm.

| improve this answer | |
  • Thank you so much. its indeed a charm! I can't thank you enough! – Necktwi May 27 '17 at 6:24
  • but I need to delete it and run it again after desktop starts. and it works for some 30 min – Necktwi May 27 '17 at 6:56
  • it seems reloading the driver every 30min is doing the trick – Necktwi May 27 '17 at 6:59
  • This is not a good command, because it replaces the existing iwlwifi.conf. I changed the file name. – Pilot6 Jan 5 at 15:02
  • Thanks it's work on 19.10 Ubuntu – milosz Feb 16 at 11:21
0

This effects Ubuntu 16.04 with 'Intel(R) Dual Band Wireless AC 7260, REV=0x144', and Bluetooth Coexist functionality but differently: /etc/modprobe.d/iwlwifi.conf.

The Intel 7260 in 802.11AC Mode does not understand the the auto _agg=0 argument which turns on Link Aggregation found in the "/etc/modprobe.d/iwlwifi.conf" file. This will cause your Wireless to stop working. Remove it, and change the command from:

echo "options iwlwifi 11n_disable=1bt_coex_active=0power_save=0auto_agg=0swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf > /dev/null
to:
echo "options iwlwifi 11n_disable=111n_disable=8bt_coex_active=1power_save=0 swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf > /dev/null

  • The focus of the Intel 7260 problem is that some BT speakers may be detected by the systems Bluetooth Manager, but unable to be used as an audio output result of the 802.11N - 13 channel Wifi band conflict with the 79 BT channels in the 2.4Ghz range (See link 1). Changing the 11n_disable=1 option removes Wireless 802.11N functionality so there is no more conflict with the unused Band. BT Loudspeakers are able to be detected, and connected, but not selected for audio output in the Sound Settings Control Panel (Pulse Audio).

  • The 11n_disable=8 option replaces the auto_agg=0 option and enables Link Aggregation needed for the Wireless AC 7260 to operate. Without it the Intel Wireless 7260 will not connect!

  • The option bt_coex_active=0 can enable the Bluetooth to operate without WLAN disconnect issues when enabling and disabling the Bluetooth "hci0" by allowing the BT device to become independent but both now *unmanaged (See link 2). In your case the disconnect or interruption of wireless service may happen when this option is set to bt_coex_active=1 because the BT blocks the Wireless because the BT thinks itself is always broadcasting. Ie. The WLAN half of the Multi-card NIC broadcasts and the BT Half thinks it is responsible for the transmission. Thus is not able to tell the difference and never shuts off while the Wireless is transmitting therefore causing interference, lagginess, etc from the conflict. However this option may remain set to bt_coex_active=1 as it isn't effected on the Intel 7260 Wireless Adapter. The following link provides visual aid to help explain why to set this option to enable if you can:


Note:
These setting used together will allow connected Bluetooth Loudspeakers to be used as an output device once selected in Sound Settings when otherwise connected without audio. Speakers such as the JBL Flip 4 can now output sound once these changes are made and a reboot has been completed. You may need to choose the "Audio Sink" Profile in the addon "Blueman Applet" but isn't needed after that)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.