After installing Ubuntu 15.04 and skype (4.3.0.37) I cannot get Skype indicator to appear in tray

I've tried doing this: http://www.ubuntugeek.com/fix-for-skypepidgin-icon-missing-from-ubuntu-15-04kubuntu-15-04.html

But the icon just doesn't appear after installing those (even after rebooting the system).

I've also tried installing dconf-editor to whitelist all the icons in Unity just like shown here: How do I access and enable more icons to be in the system tray? But I don't have such option as "panel" under the "Unity" dropdown!

How can I make the indicator show up in the tray bar? I had it working in Ubuntu 14.04

  • Is Skype autostarted? – Gunnar Hjalmarsson Jul 6 '15 at 8:52
  • Are you asking if it's autostarted when booting the system? No, I choose it from Dashboard – user2394156 Jul 6 '15 at 9:47
  • I have the same problem – elichai2 Dec 25 '15 at 8:52

Here http://ubuntuforums.org/showthread.php?t=2276023 posted the solution worked for me finally on 15.04.

sudo apt-get install sni-qt:i386

Then need to restart Skype.

  • Does not work for me, using Ubuntu 14.04 32 bits. – Hibou57 Nov 23 '15 at 19:08
  • Doesn't work for me either – elichai2 Dec 25 '15 at 8:52
  • This used to work for me on 14.04, but it stopped working when I upgraded. Tbh, I'm surprised Skype even functions properly, considering it's programmed for Ubuntu 12.04 LTS. I just migrated to Google Hangouts and TeamSpeak. – SuperSluether Jan 4 '16 at 0:56
  • Tested many things and options and finally this one worked for me (fresh install of Ubuntu 14.04 LTS)! Yay! – madcorp Jan 5 '16 at 21:59
  • 9
    It works also on 16.04. – Andrea May 7 '16 at 20:01

Running the following command solved my problem:

sudo apt-get install libappindicator1
  • 1
    Doesn't work for me: I have libappindicator1 installed. Skype running. No Skype icon in system tray. – Sergey Sergeyev Aug 1 '15 at 19:32
  • Doesn't work for me either – elichai2 Dec 25 '15 at 8:52

this happens to me, only when skype is in autostart (i use lubuntu 12.04)

sudo nano /etc/xdg/lxsession/Lubuntu/autostart i added skype:

@skype %u

this works for some months, and when skype history become big, it stop working (skype is loaded, but without tray icon) first time i fixed it with deleting /home/$user/.skype but after history was growing same happens. i run skype again and give him exit, and on second run skype have tray icon. i deside to make delay for skype:

sudo nano /etc/xdg/lxsession/Lubuntu/autostart

(this is path for Lubuntu, for Ubuntu it's different)

@/home/myuser/.skype.sh

and create in /home/myuser/ batch file .skype.sh (i want the file to be hidden):

sleep 10 && skype %u &

i saved file and make executable:

chmod +x .skype.sh

then reboot...

sorry for my poor english

Install dconf tools:

sudo apt-get install dconf-tools

Open from the terminal:

dconf-editor

Go to: com -> canonical -> indicator -> messages

In "messages", go to the label "applications" and in values, enter 'skype', including the single quotes, like so:

['skype']

Then restart the computer and open Skype.

After downloading 4.3.0.37-1_i386.deb and installing on 14.04 I had the same problem. I tried all the suggestions, but none worked.

Finally I removed the deb installation and used Software Center to install it (4.3.0.37). And the indicator works perfectly.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.