1

It seems repetitive even to myself asking this but I've searched this forum and have not been able to fix my issue. I had created one extended partition and installed my UBUNTU 14.04 on it.

Now I have 440 GB available so have recently created two new primary partitions on the free space. But when I click them to mount and access them from the "Places" menu (I have installed Ubuntu-mate) the only thing there I would have is a window opened and I can not create anything on it.

I figured it may have been mounted as root and I have not a single clue how to change it to my username. Could you please help me?

2

This is as i suppose is by mounting your partition read only,so either you have to remount with write permissions or add to fstab to autmount automatically.

Get the UUID

Run the command:

sudo blkid 

Then open /etc/fsatb:

sudo gedit /etc/fstab

Now add the line to the bottom of /etc/fsatb:

UUID=UUID /mounting-point ext4 defaults  0      2

Replace UUID with result of your UUID of /dev/sdX

Replace /mounting-point with path to mount the partition on

Reaplce ext4 with your partition filesystem type

2
  • @Maytux : thank you very much for posting the answer to me. I am going to check it right now. I have also found an other way which I started to describe right after your answer. I wish you the best and, thank you very much again.
    – Tower
    Jul 6 '15 at 13:32
  • You are welcome and your answer is good +1)
    – Maythux
    Jul 7 '15 at 10:08
1

Ok, This can be the solution:

1- Type the "lsblk" command to see the drives that are seen by your distribution and decide which one you want to mount (in my case it was /dev/sda3) and where you want to set to be its mount point (I chose it to be /mnt/EXTRA_I).

2-use the mount command using sudo like this:
sudo mount -Rc /dev/sda3/ /mnt/EXTRAS_I (you can learn more about the commands above by typing the command name first, and a --help after it. example:mount --help`)

3-Now type your password as you've been asked to do so.

4-Type lsblk again, and observe that your drive chosen is mounted (one of the fields below "MOUNTPOINT" now contains a strins value. in my case: /mnt/EXTRAS_II).

5-it is time to change the owner from "root" to your own. It was "koorosh" in my case. Example: sudo chown -Rc koorosh:koorosh /mnt/EXTRAS_I

6-Observe the prompts of output that declares the mount point is now yours.

7-Congradulations, You have succeeded, and the next time you want to mount the drive (in my case: EXTRAS_I) and view the contents of it, you will have to just double-click on its name in your file manager.

lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 465.8G 0 disk ├─sda1 8:1 0 2.8G 0 part [SWAP] ├─sda2 8:2 0 1K 0 part ├─sda3 8:3 0 210.9G 0 part ├─sda4 8:4 0 219.5G 0 part ├─sda5 8:5 0 7.5G 0 part / └─sda6 8:6 0 25.1G 0 part /home sr0 11:0 1 1024M 0 rom sudo mount /dev/sda3/ /mnt/EXTRAS_I lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 465.8G 0 disk ├─sda1 8:1 0 2.8G 0 part [SWAP] ├─sda2 8:2 0 1K 0 part ├─sda3 8:3 0 210.9G 0 part /mnt/EXTRAS_I ├─sda4 8:4 0 219.5G 0 part
├─sda5 8:5 0 7.5G 0 part / └─sda6 8:6 0 25.1G 0 part /home sr0 11:0 1 1024M 0 rom
sudo chown -Rc cockroach:cockroach /mnt/EXTRAS_I changed ownership of /mnt/EXTRAS_II/lost+found’ from root:root to cockroach:cockroach changed ownership of /mnt/EXTRAS_II’ from root:root to cockroach:cockroach sudo umount /dev/sda3

1
  • If there is already ext-formatted data on that partition, this method is going to wipe ALL of the permissions on those files. This is a nuclear option. ONLY use it if you don't have any data (read: an OS!) on that partition. Oct 13 '17 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.