5

I have recently installed Ubuntu 14.04 LTS on my MacBook Pro. But whenever I use more than 20 minutes it gets scorching hot. I tried installing laptop mode but apparently it doesn't exist.

I found something about running on efi vs bootcamp. Is that the reason why? If so can anyone explain how to fix it or suggest a link?

Could it be other reasons?

Also I had Yosemite so I used rEFInd

5
  • Please edit your question and add output of lspci -k | grep EA2 'VGA|3D' terminal command.
    – Pilot6
    Jul 6, 2015 at 4:20
  • @Pilot6 I get no such file or directory
    – JayC
    Jul 6, 2015 at 6:10
  • There is a typo in command. The correct one is lspci -k | grep -EA2 'VGA|3D'
    – Pilot6
    Jul 6, 2015 at 9:04
  • @Pilot6 hmm do i need to install nvidia driver?
    – JayC
    Jul 6, 2015 at 15:55
  • Is there only Nvidia adapter? There must be Intel too. And you do not need to make pictures. Just copy text from the terminal.
    – Pilot6
    Jul 6, 2015 at 15:57

3 Answers 3

6

You need to install Nvidia driver and also a switch utility.

Run in terminal

sudo apt-get install nvidia-331 nvidia-prime

and reboot.

Without the driver both Nvidia and Intel adapters consume power and that is why the laptop is heating.

You can check which adapter is working by

prime-select query

Switch to Nvidia by

sudo prime-select nvidia

switch to Intel by

sudo prime-select intel

Or do in in GUI Nvidia-Settings program.

enter image description here

9
  • I installed and rebooted my computer. How do i switch utility? and how do i verify only one of the adapters is working?
    – JayC
    Jul 6, 2015 at 17:08
  • You can start "Nvidia Settings" program. The switch is there.
    – Pilot6
    Jul 6, 2015 at 17:09
  • I am at Nvidia settings but do you by any chance know which tab contains the switch?
    – JayC
    Jul 6, 2015 at 17:12
  • Just look around. I do not have this hardware now. And I wrote how to do it in terminal.
    – Pilot6
    Jul 6, 2015 at 17:13
  • @JayC Added the picture.
    – Pilot6
    Jul 6, 2015 at 17:15
3

The problem got sorted out for me.
I am running 16.04 on Macbook pro retina 2015

sudo add-apt-repository ppa:mactel-support
sudo apt-get update
sudo apt-get install macfanctld

After installing it, view its manual by running

man macfanctld

it will show the config file path. Mostly it will be the below path

 /etc/macfanctl.conf

Open the config file and edit it according to your needs. I will post my config file here which is working perfectly fine for Macbook Pro 13 inch retina.

# Config file for macfanctl daemon
#
# Note: 0 < temp_X_floor < temp_X_ceiling
#       0 < fan_min < 6200       

fan_min: 4000

temp_avg_floor: 30
temp_avg_ceiling: 40

temp_TC0P_floor: 30
temp_TC0P_ceiling: 40

temp_TG0P_floor: 30
temp_TG0P_ceiling: 40

# Add sensors to be excluded here, separated by space, i.e.
# exclude: 1 7
# will disable reading of sensors temp1_input and temp7_input.

exclude:

# log_level values:
#   0: Startup / Exit logging only
#   1: Basic temp / fan logging
#   2: Log all sensors  

log_level: 0

Save the config file and restart for safety. This package seems to run like a daemon on the background and control the fan speed. I can hear fan speeds dynamically changing from the fan noise.

3
  • 1
    When you say sorted out, what temperature does your MBPro run at? I've tried every single thing I could find. Including disabling offending interrupts. TLP, Powertop, laptop-tools, fan control daemons, disabling dGPU, etc. I can't get my CPU heat lower than 45-50 degrees during idle. My MB Pro generally runs around 30-40 degrees in macOS, and hardly spikes over 55 degrees. On Ubuntu or Arch it goes up to 80 degrees quite easily.
    – nenchev
    Nov 23, 2017 at 19:04
  • I have edited my answer. Please refer it now. Nov 29, 2017 at 9:36
  • No need for ppa in Ubuntu 20.04
    – Clèm
    Jun 7, 2020 at 18:23
0

Yes, enabling EFI mode has worked for some people: My ubuntu macbook pro feels warm, can I solve this?

Here is the link to install laptop mode: http://samwel.tk/laptop_mode/packages/tarball

You can disable animations and effects from CompizConfig Settings Manager so that your laptop runs cooler.

http://www.rodsbooks.com/ubuntu-efi/index.html gives you a lead how to boot your mac with EFI.

1
  • i just realized that if i'm using rEFInd, i am using EFI instead of bootcamp. But that still makes my laptop burning hot. Also, i tried laptop mode and couldn't find a package.
    – JayC
    Jul 6, 2015 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.