How can I stop workspaces from switching automatically to other workspaces when selecting different applications?

I personally find it extremely annoying, and bad UI, to have the context/rug/workspace be pulled from underneath me and I want to prevent, under any circumstance, except of my own choosing the automatic workspace re-adjustment program that Unity (and OSX, but that's another story) imposes on me. Is there a way to do this?



The interface solution that I'm looking for exists already in Gnome "Classic", unfortunately it is not as nice of a desktop as Unity or Gnome3, it has a simple bar at the top and an open windows bar at the bottom of the screen, and on this bottom bar there are 4 work-spaces screens on the right side, it is these that work exactly how I imagined a good work-space should work -- that is: in each work-space I can start up an application and if I switch to another one work-space I can start up the same application without being switched to my previous works-pace.

I imagine if this behavior exists already that someone with deep knowledge about the work-space or perhaps a developer that has worked on these or their updated counterpart in Unity could let me know how the appropriate settings can be manipulated in Unity to bring back the behaviour of the work-spaces similarly to gnome 'classic'.

  • Can you elaborate on how you expect the thing to work? I.e. if you do have an appication open on another workspace and you click on its icon in the launcher - what would you expect to happen? – Sergey Oct 6 '11 at 22:48
  • Yes, in that case, I would like the application to just open another window or instance in the workspace that I am currently in. I don't mind multiple windows of the application or the entire application existing twice. But, in the short term the biggest problem I have is with Nautilus, or with the Ubuntu file manager, if that one could stop moving my workspace around it would be great. But of course, for the sake of consitency, I do want to have a way to just make the workspace kind of it's own isolated world... – Victor S Oct 6 '11 at 23:21

Actually the easy answer would be to middle click on the app icon in the Unity launcher to launch another instance of the application if it's already opened in whatever virtual desktop you find yourself in.

| improve this answer | |

I think you may look into running multiple X sessions instead of using workspaces - this way they'll be totally isolated from each other, I think you even may be able to run different window managers in them.

You can start an additional X server using something like

startx -- :1

which you then will be able to access by pressing Alt-Ctrl-F8..12

I tested it and was able to run a KDE session at Alt-Ctrl-F7 and a Gnome session at Alt-Ctrl-F8, so, as you can see, the isolation is perfect. Though it maybe a bit of an overkill for the problem you have...

Here's an article showing how to run two sessions with different window managers (tough, of course, you can use Unity on both).

Note that you need to edit your /etc/X11/Xwrapper.config and set allowed_users=anybody to be able to run as a non-root user.

There also some restrictions in terms of running two instances of a same program as a same user in two different X sessions, because they may step on each other feet and overwrite each other's settings - so to be able to run, say, Firefox, you may need to create two separate profiles.

| improve this answer | |
  • Interesting, I will try it, I wonder if this can be wrapped into some GUI widget like Workspaces but with the behaviour your describe... – Victor S Oct 8 '11 at 2:50
  • Hmm, not exactly how I imagined, it throws me into some netherworld, as well, I have to sudo startx -- :1, the desktop is completely different, probably because now I'm root. – Victor S Oct 8 '11 at 2:58
  • I updated the answer – Sergey Oct 8 '11 at 20:47
  • The issue with running two instances of applications as same user seems to bring up more questions... I'm guessing virtualizing your desktop to support a kind of 'sessions' based workspaces that are completely self contained is maybe too much to ask from current implementation of Linux/Ubuntu? I guess it's this issue that forces Ubuntu to simply not allow starting up multiple instances of applications; but simply switches to the currently running application if you try to run it again. – Victor S Oct 9 '11 at 23:00
  • I wouldn't mind if the same instance of the application is running, my original concern was with simply opening a new window of that application in the current workspace -- instead of moving my workspace to some existing open window of that application in another workspace. Configuring this behaviour without resorting to separate X11 sessions is not possible? – Victor S Oct 9 '11 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.